Site components generating 503 errors

Discussion in 'General' started by dlarmeir, Jul 10, 2010.

  1. dlarmeir

    dlarmeir Member

    Hello All,

    I have a site that is generating the following errors on some PHP files:
    2010-07-10 11:59:12.954 [INFO] [] connection to [/tmp/lshttpd/mydomain.com_lsphp.sock.441] on request #0, confirmed, 1, associated process: 6923, running: 0, error: Connection reset by peer!
    2010-07-10 11:59:12.954 [NOTICE] [] Max retries has been reached, 503!
    2010-07-10 11:59:12.954 [NOTICE] [] oops! 503 Service Unavailable
    2010-07-10 11:59:12.954 [NOTICE] [] Content len: 0, Request line:

    These PHP files were working up until the last couple of days. I have tried recompiling PHP to both version 5.2 and 5.3 but the same issues persist. The platform I am running is wordpress 3.0 - Any suggestions? The log files do not seem to be verbose enough to lead me to a specific issue.:eek:

    Thanks, Dustin
  2. NiteWave

    NiteWave Administrator

    have you installed any new wordpress plugin which need special php decoder/loader?

    A recent experience of mine:
    some important files need phpshield loader, but not put in right place for php 5.2.x on 64-bit OS (might be ok for 5.1.x)

    generally, if you've installed new plugins in recent couple of days, try to disable them first, see if 503 disappear.
  3. dlarmeir

    dlarmeir Member

    NiteWave, thanks for the help and suggestion. The way we were able to resolve this was to switch the script handler from the vhost level to the server level. I am not 100% sure why that fixed it but I guess there was a problem with the vhost script handler configuration. I ruled out the plugin itself by testing it on another Litespeed server with the same PHP version, configuration etc.

Share This Page