[solved] 4.0.18: .htaccess / PHP Issue

Discussion in 'Bug Reports' started by JulesR, Dec 12, 2010.

  1. JulesR

    JulesR Member

    Upgraded to 4.0.18 and now after a period of approximately an hour (possibly irrelevant), the server begins to refuse to parse/read .htaccess files.

    As an example, Wordpress blogs with SEO enabled URL's throw up a 404 error message.

    Anyone else seeing this behavior?
    Last edited by a moderator: Mar 14, 2011
  2. mistwang

    mistwang LiteSpeed Staff

    We need more details in order for us to investigate. It will be a lot easier if it could be reliably reproduced.
    There is no code changes in 4.0.18 directly related to .htaccess file handling.
  3. JulesR

    JulesR Member

    Well what information do you need and how do I provide this to you?

    Since I can reproduce this reliably something has obviously changed. Mod_rewrite implementation perhaps?
  4. mistwang

    mistwang LiteSpeed Staff

    Please send us the detail on how to reproduce the problem along with temp root access to the server.
  5. JulesR

    JulesR Member

    I told you how to reproduce it....

    I'll only grant temp root access to the server via MSN or some other means, since it's a production server and I can't have the downtime whilst I wait for you guys to login and investigate. It'd need to be handled in realtime.
  6. JulesR

    JulesR Member

    Thanks for ignoring this issue. Not impressed with the level of support regarding this at all. I'm bringing this one up again because it's happening with your latest release of 4.0.18. PLEASE do something about this, as it's clearly a bug in your software.

    Debug log information:

    2011-01-04 20:04:03.100 [NOTICE] [xx.xx.xx.xx:3182-0#APVH_domain.com] Content len: 0, Request line: 'GET /about/ HTTP/1.1'
    2011-01-04 20:04:03.100 [DEBUG] [xx.xx.xx.xx:3182-0#APVH_domain.com] Find context with URI: [/], location: [/home/path/public_html/domain.com/]
    2011-01-04 20:04:03.100 [DEBUG] [HTAccess] Updating configuration file [/home/path/public_html/domain.com/.htaccess]
    2011-01-04 20:04:03.100 [DEBUG] [HTAccess] No change in configuration file [/home/path/public_html/domain.com/.htaccess].
    2011-01-04 20:04:03.100 [DEBUG] [xx.xx.xx.xx:3182-0#APVH_domain.com] Find .htaccess context with URI: [/], location: [/home/path/public_html/domain.com/]
    2011-01-04 20:04:03.100 [DEBUG] [xx.xx.xx.xx:3182-0#APVH_domain.com] [REWRITE] Rewrite engine is not enabled for context '/'
    2011-01-04 20:04:03.100 [INFO] [xx.xx.xx.xx:3182-0#APVH_domain.com] File not found [/home/path/public_html/domain.com/about/]

    So, rewrites aren't working. What is "Rewrite engine is not enabled for context '/'"?
  7. foliovision

    foliovision Member


    are there any news on this issue. We just installed LSWS on a barebone server (without cpanel) and .htaccess is not being parsed. Are there any known issues or options during install which should be avoided/updated? We did the same install on a different server where it works straight out of the box.

    Best regards,
  8. NiteWave

    NiteWave Administrator

    JulesR's issue has been fixed around Jan 27, with the 4.0.19 release.
    "caught the bug with debug logging enabled,related to a new feature back ported from 4.1RC release"

    your issue looks different. if .htaccess not being parsed from the begining, it should be lot easier than "after about 1 hour, .htaccess not working".

    please enable rewrite log and test on a simplest rewrite rule, to trouble shoot it.

    will mark this thread as "solved" if no surprise within 24 hours.

Share This Page