[solved] 4.2.4 won't ForceType per .htaccess

Discussion in 'Bug Reports' started by gboudreau, Aug 16, 2013.

  1. gboudreau

    gboudreau Well-Known Member

    My .htaccess file:
    <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteCond %{HTTP_USER_AGENT} ^MJ12bot/v1\.0\.8.*$
        RewriteRule .* - [F]
    <FilesMatch "^(/||[en/]*index\.html|[en/]*Evenements.*\.html)$">
      ForceType application/x-httpd-php
    With lsws 4.2.3, the file Evenements.html is correctly parsed using PHP.
    With lsws 4.2.4, the same file just sends the PHP source to the browser.
    I can reproduce this by simply using the "Switch To" link in the version manager, and the issue goes away when I again "Switch To" 4.2.3

    Last edited by a moderator: Aug 17, 2013
  2. mistwang

    mistwang LiteSpeed Staff

    please do

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.4

    should be fixed now.
  3. gboudreau

    gboudreau Well-Known Member

    Thank you. That fixed it.

Share This Page