[solved] 503 error - only in WP backend

Discussion in 'General' started by Jesse, May 14, 2012.

  1. Jesse

    Jesse Member

    Hey guys,

    Hoping someone can lend me a hand here. We've got a website which works fine, except when using the wordpress admin panel - which under LS 4.1.12 provides a 503, but switching back to Apache it works without issue.

    The errors logged are:

    2012-05-14 10:41:37.042 [INFO] [112.xxx.xxx.xxx:56798-0#APVH_domainname.com.au] connection to [/tmp/lshttpd/APVH_domainname.com.au_Suphp.sock] on request #0, confirmed, 1, associated process: 871422, running: 0, error: Connection reset by peer!
    2012-05-14 10:41:37.320 [INFO] [112.xxx.xxx.xxx:56798-0#APVH_domainname.com.au] connection to [/tmp/lshttpd/APVH_domainname.com.au_Suphp.sock] on request #0, confirmed, 1, associated process: 871423, running: 0, error: Connection reset by peer!
    2012-05-14 10:41:37.591 [INFO] [112.xxx.xxx.xxx:56798-0#APVH_domainname.com.au] connection to [/tmp/lshttpd/APVH_domainname.com.au_Suphp.sock] on request #0, confirmed, 1, associated process: 872453, running: 0, error: Connection reset by peer!
    2012-05-14 10:41:37.591 [NOTICE] [112.xxx.xxx.xxx:56798-0#APVH_domainname.com.au] Max retries has been reached, 503!
    2012-05-14 10:41:37.591 [NOTICE] [112.xxx.xxx.xxx:56798-0#APVH_domainname.com.au] oops! 503 Service Unavailable
    2012-05-14 10:41:37.591 [NOTICE] [112.xxx.xxx.xxx:56798-0#APVH_domainname.com.au] Content len: 0, Request line: 'GET /wp-admin/ HTTP/1.1'
    2012-05-14 10:41:37.591 [INFO] [112.xxx.xxx.xxx:56798-0#APVH_domainname.com.au] Cookie len: 461, wordpress_2036f50e6c89287596add14af138ab02=admin%7C1337128024%7Cef81e4be7fb0272528d49325e46f8d12; wordpress_test_cookie=WP+Cookie+check; wordpress_logged_in_2036f50e6c89287596add14af138ab02=admin%7C1337128024%7Cd2aae93e55ba15e24e3bd4560a4bcada; wp-settings-1=m5%3Do%26m13%3Do%26m9%3Do%26m10%3Do%26m11%3Do%26m15%3Do%26editor%3Dtinymce%26imgsize%3Dfull%26align%3Dnone%26m3%3Do%26m16%3Do%26galfile%3D1%26galcols%3D1%26m1%3Do%26m4%3Do; wp-settings-time-1=1336955225
    We've ruled out a custom php set by clearing away their account level custom php.ini, checked permissions, raised their memory_limit to 256M, disabled mod_sec, and have tried without their .htaccess (which is just standard wp mod_rewrite). Just not really sure, and given it's working under apache it's really really strange.

    php is 5.3.10.

    Any ideas?

    Last edited by a moderator: May 14, 2012
  2. NiteWave

    NiteWave Administrator

    any message in stderr.log? have you enabled opcode cache ?
  3. Jesse

    Jesse Member

    Thanks, I didn't even know that file existed (looks ls specific) so I've now found that which revealed:

    2012-05-14 12:03:06.721 [STDERR] lsphp5:/home/cpaneluser/public_html/wp-admin/index.php: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20090626/pdo_sqlite.so: undefined symbol: sqlite3_libversion
    Further investigation drew me to this - http://forums.cpanel.net/f5/undefined-symbol-sqlite3_libversion-148993.html#post632357 - which appears to be spot on, as commenting out pdo_sqlite resolved the 503. Although, 2 years on it's surprising php haven't corrected this :confused:

  4. NiteWave

    NiteWave Administrator

    Thanks for the update. so lsphp5 crashed due to "undefined symbol: sqlite3_libversion", which caused 503 error.
  5. Jesse

    Jesse Member


    Is there any chance this could be resolved from the LS side of things without having to disable pdo_sqlite?
  6. NiteWave

    NiteWave Administrator

    it looks that pdo_sqlite is built in lsphp5 by default. so no need pdo_sqlite.so at all.

    "The PDO_SQLITE PDO driver is enabled by default. To disable, --without-pdo-sqlite[=DIR] may be used"

    put phpinfo.php under a folder, and access it. search "pdo_sqlite", it's there in a lsphp 5.3.10 build at my local test box.
    "SQLite Library"

Share This Page