[solved] A valid URL was not provided


I am using LiteSpeed Cache Image Optimization v2.9 for WordPress.

Everything worked fine with image optimization till some days back:

Current Stage Status
Images optimized and pulled: 1608 groups (11053 images)

Image Information
Images total: 1648 groups
Images not yet requested: 76 groups

Optimization Summary
Total Reduction: 143.28M
Images Pulled: 8817
Last Request: 12/23/2018 10:27:52

Storage Optimization
Last calculated: 01/06/2019 21:25:36
Files: 11053
Total: 1.31G
Now when i press “Send optimization request” i receive an error:
IAPI Error A valid URL was not provided.
I tried to reset IAPY Key (with success)

“Clean up unfinished data” now gives 2 errors:
IAPI Error A valid URL was not provided.
A valid URL was not provided.

thanks for any help,


Last edited by a moderator:


Staff member

Please share your Environment Report: Navigate to LiteSpeed Cache > Report, press the Send to LiteSpeed button, and let us know what it says under "Report Number." We'll be able to access the report from here and get some information about your configuration that might be helpful.


Here is: Report number: JFFFJUZG
Also on that page i have on top IAPI Error A valid URL was not provided.

thank you,
Last edited by a moderator:

Hosting company gaved a solution that under cPanel -> Select PHP Version -> Switch To PHP Options
remove everything at "disable_functions" (fsockopen, passthru, system, dl, proc_open, proc_close, shell, shell_exec, ini_alter, ini_restore, popen, escapeshellarg, escapeshellcmd, pcntl_exec, proc_terminate, proc_nice, error_log, syslog, link, symlink, proc_open_status, readlink, virtual, shell, mysql_pconnect, exec, disk_free_space, diskfreespace, disk_total_space, getmyuid, getmypid, getrusage, highlight_file, php_uname, show_source, proc_get_status, posix_kill, posix_mkfifo, posix_setpgid, posix_setsid, posix_setuid, posix_getpwuid, allow_url_fopen)

After that works again.