[SOLVED] AWS Wordpress interactive script doesn't run after install


I am following the LiteSpeed WordPress Quickstart guide but get stuck on step 3. Please see my progress through the guide below. Any help to proceed is appreciated.

Step 1
I launched a WordPress with LiteSpeed Cache (Powered OpenLiteSpeed) Server through the machine image found on AWS.
Version: 5.9
Operation System: Linux/Unix, Ubuntu 20.04 | 64-bit (x86)
Updated: 2/7/22 (American date format)
EC2 instance: t3a.nano
Storage: 8GB (GP2 SSD)
[EDIT: now references correct AWS image]

Step 2
I can connect to the server by SSH through AWS's cloud console and separately using a local SSH client. Both ways are successful.

(I also confirmed that when I navigate to the server in a browser I can see the OpenLiteSpeed welcome page that reads Please log into your Server with SSH to configure the WordPress installation.)

Step 3
The guide reads: An interactive script that runs will first prompt you for your domain or subdomain. However, no such script runs. I can see what the script is supposed to look like on YouTube. I do not see this. Instead, I see the standard command line entry point.

Additional troubleshooting
I saw a previous post on this forum where a user solved the issue by re-installing the image. This solution did not work for me. I have installed two separate images and both fail to render the interactive script at step 3.

Last edited:
I solved this issue by launching an EC2 instance of type t2.nano instead of t3a.nano. All else is equal. I can now see the interactive script and proceed with the guide.

It appears t3a EC2 types (which are AWS servers using AMD Ryzen CPUs) cause a compatibility issue which stops the interactive script from running.
Last edited: