[solved] Cannot enable gzip compression.

#1
Hi!
I would appreciate any help on this one:
http://www.zenmony.com/okinawa-fucoidan-c8/
In my LiteSpeed config gzip compression seems to be enabled, but when I cheched response headers I do not see Content-Encoding: gzip.
Also I would like to hide or change these response headers:
Server: LiteSpeed
X-Powered-By: PHP/5.3.23

Thank you!
 
Last edited by a moderator:

NiteWave

Administrator
#2
In my LiteSpeed config gzip compression seems to be enabled, but when I cheched response headers I do not see Content-Encoding: gzip.
please upgrade to latest 4.2.4
refer http://www.litespeedtech.com/litespeed-web-server-release-log.html
Fixed a bug causing MIME types such as "text/css; charset=..." to not be gzipped when GZIP is enabled for "text/*".
see if it just fixes your site's issue.

Also I would like to hide or change these response headers:
Server: LiteSpeed
X-Powered-By: PHP/5.3.23
in lsws admin console,
Server->General->Server Signature: select "Hide Full Header"
 
#3
Hi,
thanks for your reply!
However upgrading to 4.2.4 did not resolve the issue.
I have text/* in compressible types.
Where else can I look at?
Should I try adding gzip settings to .htaccess?

Thank you.
 

NiteWave

Administrator
#4
may not need.

can you post the setting in your
lsws admin console
->Server
->Tuning
->GZIP Compression

or PM your admin console's access so I can take a quick check.
 
#6
Thanks for telling. Yes, I had to enable gzip in php.ini
zlib.output_compression = On
Now I can see it works with html and text,
but I still don't see gzip header with css and js files.
Is it the way it should be?
Thanks.
 

NiteWave

Administrator
#7
yes, by default, css/js etc is gzip'd.
and no need
zlib.output_compression = On

there must be a setting somewhere which override the default setting.
 

NiteWave

Administrator
#9
while I still can't see "Content-Encoding:gzip" response header for js/css, per your feedback, I'll mark this thread as [solved]. maybe you disable the gzip purposely.
 
#11
it is still wildcard issue ,

I added


text/*, application/x-javascript, application/xml, application/javascript, text/css, text/javascript, text/js

and it started working , but still singeling out some files like style.css?ver=1.0.0

not seeing it as CSS
 
Top