[solved] Cannot use 2 LiteSpeed Admin on same browser at the same time

Discussion in 'Bug Reports' started by redstrike, Sep 19, 2011.

  1. redstrike

    redstrike Well-Known Member


    I have 2 VPS, each i installed LiteSpeed. And i've tried to manage both of them at the same time on the same browser. The one which i logged is active, and the next one is not working. Below is the error:

    ERROR [ADMIN] authentication failed!
    Please fix it.
    Last edited by a moderator: Sep 21, 2011
  2. webizen

    webizen Well-Known Member

    are you saying when accessing your lsws admin cp from two tabs, respectively, within the same browser, one is successful but the other fail?

    if so, with the tab of successful login being closed, does the other admin cp still fail. IOW, are you able to get in if access it from a separate browser?
  3. redstrike

    redstrike Well-Known Member

    Two tabs, same browser => 2 is successful login, but the second one will show that error inside, and not show realtime stats, every features can be access but not work.

    If i just closed the "working ok" tab, another still be that error. Log out both of them is ok. Separate browsers is OK. I have tried to change the port, change user name, etc.... but still not work.
    Last edited: Sep 20, 2011
  4. anything

    anything Well-Known Member

    im regularly logged into several litespeed severs cp's at the same time, mostly to copy my settings from one to another when setting a new one up.

    ive also used it to show the # http requests plotted from 4 servers in the one browser window (html page with iframes)
  5. mistwang

    mistwang LiteSpeed Staff

    If web consoles of two servers use the same IP on different port, you will get this issue.
    That's because browser disregards port number, only use IP/domain for its cookies. browser could not tell it apart, it is not a bug in LSWS, nor something we can fix.

    You have to use two browsers, or use different domain/IP to access different server.
  6. redstrike

    redstrike Well-Known Member

    I found that it is the IE9 issue. Chrome or Firefox is working normally. Thanks.

Share This Page