[solved] Compiling PHP: Unrecognized options: --with-litespeed

Discussion in 'Install/Configuration' started by theRKF, Jul 4, 2014.

  1. theRKF

    theRKF Well-Known Member

    For reasons I won't go into right now (too lengthy) we have to compite PHP from the command line. When we set up this server we paid for the LiteSpeed techs to install two versions of PHP - 5.2.17, and at the time 5.3.something. I've been regularly compiling and updating the 5.3.x branch right through to 5.4.30, but never had to do anything with the 5.2.17 version until now.

    Today we upgraded MySQL from 5.1 to 5.5. This broke both PHP installations, so we rebuilt 5.4.30 without a problem.

    However, the 5.2.17 rebuild is not going so well. I have downloaded the source, LSAPI (first 6.2, then 5.5), as per the instructions ... but when I run ./configure it always outputs
    configure: WARNING: unrecognized options: --with-litespeed
    Any suggestions on what to do?
  2. NiteWave

    NiteWave Administrator

    theRKF likes this.
  3. theRKF

    theRKF Well-Known Member

    Thank you!

Share This Page