[solved] Configuring PHP with Litespeed for Jpeg GD Support

Discussion in 'PHP' started by QuickVPS, Nov 18, 2010.

  1. QuickVPS

    QuickVPS New Member

    I have recently installed Litespeed Web Server and have been overall happy with it and it's playing well with our websites, but in particular I am having trouble getting it to support Jpeg GD.

    I configured PHP 5.2.14 with the following attributes on a CentOS 5 64bit system with cPanel:
    '--with-mysqli' '--with-zlib' '--with-gd' '--enable-shmop' '--enable-track-vars' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-magic-quotes' '--enable-mbstring' '--with-iconv' '--with-libdir=lib64' '--with-mysql' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-litespeed' '--with-jpeg-dir' '--with-png-dir'

    I have not specified a directory for Jpeg and PNG because it's in the default /usr/lib and /usr/lib64 directories (I have tried specifying the directory as well with no luck).

    The .so files are definitely in boh of those directories:

    [root@server lib]#ls *libjpeg*
    libjpeg.so libjpeg.so.62 libjpeg.so.62.0.0

    [root@server lib64]#ls *libjpeg*
    libjpeg.so libjpeg.so.62 libjpeg.so.62.0.0

    And the correct RPMs are installed:

    [root@server public_html]#rpm -qa|grep jpeg

    Could someone recommend a way forward to get PHP to play with Jpeg GD?

    Here is the full build log: quickvps.co.uk/buildlog.txt
    Last edited by a moderator: Nov 19, 2010
  2. QuickVPS

    QuickVPS New Member

    Found the answer in the end. Even though the .so files are in /usr/lib/ and /usr/lib64, the build has to be as follows:
  3. csdco

    csdco Member

    Worked great, thanks.

Share This Page