[solved] CSF Firewall and mod_security

Discussion in 'Feedback/Feature Requests' started by stormy, Aug 7, 2014.

  1. stormy

    stormy Well-Known Member

    Given all the improvements in Litespeed's mod_security compatibility (thank you!) I think it's time to request this fix:

    For some reason, the CSF firewall and Configserver's Modsecurity Control can't read the rule ID when using Litespeed.

    Here are some screenshots to make it easier to understand. Please note the "unknown" in the ID fields.

    Can this be fixed easily? I know we can't really count on CS fixing the script in order to accomodate Litespeed.

    Captura de pantalla 2014-08-07 20.36.50.png

    Captura de pantalla 2014-08-07 20.39.27.png
  2. Michael

    Michael Well-Known Member Staff Member


    What LSWS version are you using? I know we fixed a very similar problem in 4.2.13.


  3. stormy

    stormy Well-Known Member

    You are right! I was on 4.2.12. Just upgraded to 4.2.14 and I can see the rule ID. Fantastic! :D

    BTW I just subscribed to the announcements forum so I can be notified of new releases :)
  4. Michael

    Michael Well-Known Member Staff Member

    Good idea. Actually, your servers should be getting emails to the admin email when new versions are pushed to autoupdate.

    Glad it worked!



Share This Page