[solved] Fail to Swith to LiteSpeed or Restart

Discussion in 'General' started by milliondollar, Mar 28, 2014.

  1. milliondollar

    milliondollar Active Member


    I just install my VPS with cPanel/WHM & Litespeed v4.26. I have 2 CPU license which I can only install up to v4.26.

    As I unable to install via cPanel plugins, so I install via command line. The installation works OK & I can see it in Plugins section of cPanel/WHM. After that I went to compile matching LSPHP. Its all good.

    Unfortunately I unable to to swith to Litespeed from Apache

    This is the error
    Failed to bring up LiteSpeed
    Apache Stopped.
    LiteSpeed is not up within 30 secs, try again by removing /tmp/lshttpd/.
    **ERROR** LiteSpeed is not up within 60 secs, please check the error log and try again.
    Apache port offset has been set to 0.

    If I Restart Litespeed when Apache not running, the error is
    LiteSpeed is not running! Please check the web server log file for errors.

    I try to recompile Apache, force build matching LSPHP & force reinstall the same version but it does not solve the problem.
  2. NiteWave

    NiteWave Administrator

  3. milliondollar

    milliondollar Active Member

    No it doesn't work. Same problem.

    Just to update. If I do force update to same version, It does run. But if I switch to Apache & subsequently want to switch back to Litespeed the same error will come out.
  4. milliondollar

    milliondollar Active Member

    I think I find out the reason for the problem, most probably licensing issue. When I force downgrade to version 4.2.5, the problem solve. When I install version 4.26 I see an error "[ERROR] You are not authorized to use this binary, please purchase upgrades." but don't see it while installing v4.25.

    So my next question is, my software upgrade expired on 3rd Jan 2014 while version 4.26 release on 22nd November 2013, why I can't use version 4.26?
    Last edited: Mar 28, 2014
  5. Michael

    Michael Well-Known Member Staff Member

    Howdy MillionDollar,

    This is because we continued to release new builds of 4.2.6 (to address bugs) until January 24th, when 4.2.7 was released. If you like, I can manually adjust your update expiration date so to make sure you have access to 4.2.6. I have sent you a private message ("started a conversation"). Just send me your serial number or IP and I'll make the adjustment.

    Sorry for the inconvenience.


  6. milliondollar

    milliondollar Active Member

    Great. The problem solved.TQ
  7. Michael

    Michael Well-Known Member Staff Member

    Again, sorry for the inconvenience!



Share This Page