[solved] Fix the litespeed forums charset bug

Discussion in 'Feedback/Feature Requests' started by wanah, Nov 18, 2013.

  1. wanah

    wanah Well-Known Member


    Whenever I submit de post with utf8 characters when I click Submit New Thread it is published with my post cut off at the first utf8 character.

    I have to click the back button in my browser copy my post, go back to the forum, click edit the post and paste my post removing any utf8 characters and if I miss one I have to restart this procedure until it's fixed.

    I don't know if this is a utf8 database issue or some sort of modsecurity rule but it is a huge pain.

    I've mentionned this issue in other topics but never got a direct answer about this specific issue.

    Could someone plus look into this issue and see what can be done to fix it ?
    Last edited by a moderator: Nov 21, 2013
  2. NiteWave

    NiteWave Administrator

    thanks for push ... I think we'll try to resolve it now. In fact I have experienced similar case which is a double-byte character but have thought that's the rare case. apparently it's quite a common issue.
  3. wanah

    wanah Well-Known Member

    In english there aren't many double byte characters for Windows or linux users that are accessible on the keyboard. However on Mac OS there are quite a few that lots of people use quite often.

    For example there is the ellipsis that mot PC users represent with ... but mac users tend to use alt + . to write (U+2026 or & hellip;). In languages other than english there are alot of characters that cause problems and people with spell check in their native language might find some worlds replaced automaticaly like for instance the letters oe in French are supposed tobe joined (& #339)

    I've added spaces after the &'s so I can save this post.
  4. NiteWave

    NiteWave Administrator

    it looks direct input is ok, see below:
    test: to input "& # 339" (delete space in it)

    Œ, œ, and the very rare Ÿ
    Č, č, Ř, ř, Š, š, Ž, ž


    the issue occur when you try to quote other's words --- all words will be lost after the special character in [ QUOTE ] part
    "[ QUOTE ]" -- added space in it.
    Last edited: Nov 19, 2013
  5. wanah

    wanah Well-Known Member

    Yes I guess if you replace characters with the htmlencoded value that the forum accepts them, but if you make the mistake of posting a single value that isn't html encoded it won't work.

    Test direct input (if you see nothing after this line then it hasn't worked) :


    Accents still don't work. (i with an accent, a with an accent)
    Last edited: Nov 20, 2013
  6. NiteWave

    NiteWave Administrator

    yes, reproduced just now.
    good news is, almost found the solution, tested on another vBulletin installation

    AdminCP > Languages & Phrases > Language Manager
    > Edit Settings
    HTML Character Set : ISO-8859-1 ==> UTF-8

    I think may apply for this forum soon
    Last edited: Nov 20, 2013
  7. NiteWave

    NiteWave Administrator

    à è ì ò ù
    à è ì ò ù 
    à è ì ò ù 
    updated vBulletin, looks OK now, see above :)
  8. wanah

    wanah Well-Known Member

    Great news… !!
    begin test :
    à ç é ê ô À É È Ê Ô Ç • ¿ ± ‰
    end test;

    Edit :

    It works :)

Share This Page