[solved] images do not display after LSWS 4.2.7 upgrade

Discussion in 'Install/Configuration' started by muiruri, Feb 22, 2014.

  1. muiruri

    muiruri Well-Known Member


    After uploading one of my servers from version 4.2.6 to 4.2.7

    The images stopped showing for many sites.

    When I switch back to Apache, images display fine.

    I noticed the option Server -> General -> PHP suEXEC appears to have changed to NO, I changed it back to YES, so that it can match or enable suPHP that is enabled in Apache.

    But this does not help.

    I have also tried going back to LSWS 4.2.6 but now have the same problem. Therefore the upgrade changed something I now cannot find.

    Any more ideas?

    Please help urgently we have many sites affected and customers upset. It's a very frustrating experience.

    Wish LSWS can release upgrades that do not mess-up things.
  2. muiruri

    muiruri Well-Known Member

    Only solution I have found to work is to manually change permissions for all files inside /public_html/ of each site from nobody to cpanel user.

    PS: This is a big problem, because we have hundreds of sites on the server.

    Do not understand why this has become a problem now and all was working fine before with version 4.2.6, which does not work anymore when we try to downgrade, same problem persists.

    We also do not want to change permissions for sites without informing users.
  3. NiteWave

    NiteWave Administrator

    lsws web admin -> Server -> Security -> File Access, especially
    Required Permission Mask
    Restricted Permission Mask
    change both to 000 to match apache if not 000
  4. muiruri

    muiruri Well-Known Member

    Both these two options are already set to 000;
    Required Permission Mask
    Restricted Permission Mask

    But still having trouble with sites loading images.
  5. NiteWave

    NiteWave Administrator

    please give the output:
    #ls -ald /home/user001/public_html

    replace above user001 to a problem cPanel user's name

    #ps -ef |grep litespeed
  6. muiruri

    muiruri Well-Known Member

    This is the output I get for one of the users;

    # ls -ald /home/user001/public_html
    drwxr-x--- 39 user001 nobody 4096 Feb 21 16:30 /home/user001/public_html

    # ps -ef |grep litespeed
    root 21316 1 0 15:07 ? 00:00:06 litespeed (lshttpd)
    nobody 21318 21316 0 15:07 ? 00:01:19 litespeed (lshttpd)
    nobody 21319 21316 0 15:07 ? 00:00:01 litespeed (lshttpd)
    root 27101 24728 0 17:20 pts/1 00:00:00 grep litespeed

    Please advise?
  7. NiteWave

    NiteWave Administrator

    the output of above 2 commands are normal.

    can you post all current settings of lsws web admin -> Server -> Security -> File Access ?
  8. muiruri

    muiruri Well-Known Member

    Following are the current settings;

    lsws web admin -> Server -> Security -> File Access

    Follow Symbolic Link - YES
    Check Symbolic Link - NO
    Force Strict Ownership - YES
    Required Permission Mask - 000
    Restricted Permission Mask - 000
    Script Restricted Permission Mask - 000
    Script Restricted Directory Permission Mask - 000
  9. NiteWave

    NiteWave Administrator

    please try:
    Force Strict Ownership - No
    then restart lsws
  10. muiruri

    muiruri Well-Known Member

    Yes, this has now helped and on a quick check of some sites, images load fine now.
  11. NiteWave

    NiteWave Administrator

    re-read the tip of this setting in lsws web admin, it can explain the issue of this thread exactly ;)

Share This Page