[solved] Indexes bug

Discussion in 'Bug Reports' started by Monarobase, Jun 10, 2013.

  1. Monarobase

    Monarobase Well-Known Member


    I've just noticed that since I updated to litespeed 4.2.3 that accounts have indexes turned on by default.

    In cPanel's configuration indexes are turned off by default and in Litespeed's configuration in lsadmin panel indexes are turned off too.

    If I sepecificaly disable indexes in a .htaccess file indexes are turned off but if I create a new account with no .htaccess file indexes for the public_html directory are on.

    I don't know if it's related but I've turned off litespeed's signature.
    Last edited by a moderator: Jun 12, 2013
  2. webizen

    webizen Well-Known Member

    Indexes is *enabled* by default in cPanel (WHM => Apache Configuration => Global Configuration => Directory “/” Options => indexes default). Once disabled, LSWS should disable autoindex for apache vhosts regardless of autoindex settings in LSWS. Nothing to do with litespeed signature hiding.
  3. Monarobase

    Monarobase Well-Known Member

    That's the problem, it has been disabled since the beginning and is still disabled and is also disabled in litespeed. How can it enable itself by default when it is both disabled in cPanel and litespeed ?

    I haven't checked the apache files to see if it's an issue with cPanel or litespeed. Updating litespeed + php with easy apache also updated Apache so this could be a cPanel bug, but this would be a first for cPanel's easy apache.

    We are running cPanel's stable release branch so we are currently running version 11.36.1 build 8 with the latest version of easy apache.
  4. webizen

    webizen Well-Known Member

    'Indexes default' in 'Directory “/” Options' indicates that it should be checked (enabled) by default. Our lab is running WHM 11.38.0 (build 16).

    Pls switch to Apache and see if autoindex is still off?
  5. Monarobase

    Monarobase Well-Known Member

    Yes it's unchecked, I will check the apache config tomorrow to see if it's wrong in cPanel or if it's an issue with litespeed
  6. webizen

    webizen Well-Known Member

    if it shows 'Indexes default' in the 'Global Configuration' but yours is unchecked, likely someone changed after install because 'default' indicates Indexes is supposed to be checked/enabled by default.
  7. Monarobase

    Monarobase Well-Known Member

    We always uncheck this option for security reasons.

    However I have found the problem, just switched to Apache and back and indexes are also turned on
  8. Monarobase

    Monarobase Well-Known Member

    There was an issue with the mail.local template that kept some things from a previous version of easyapache that is shouldn't have. Reverting to the up to date default apache template solved the issue that was making an apache rebuild fail and building with default settings.
  9. webizen

    webizen Well-Known Member

    thanks for the update.

Share This Page