[Solved] Litespeed / CageFS - Internal Server Errors

Discussion in 'Install/Configuration' started by sahostking, Jan 18, 2013.

  1. sahostking

    sahostking Well-Known Member

    Hi guys,

    I just installed Litespeed on a server of ours and selected CageFS with suexec or even just CageFS after install in configuration. But now all sites just don't load.

    They return Internal Server Error.

    If I however change it to LVE then all goes well and every site works.

    Any ideas how to troubleshoot.
     
    Last edited by a moderator: Jan 25, 2013
  2. sahostking

    sahostking Well-Known Member

    I even uninstalled and reinstalled cagefs now - no luck.
     
  3. NiteWave

    NiteWave Administrator

    configure lsphp5 in suEXEC daemon mode, see if it works
     
  4. webizen

    webizen Well-Known Member

    the issue is due to missing lsws in cagefs-skeleton.

    run below to update cagefs with lsws
     
  5. asep

    asep New Member

    [solved]

    Hi,

    I have same problem also Litespeed + CageFS
    But now it's working with command :
    cagefsctl --create-mp
    cagefsctl --remount-all
    cagefsctl --update

    But, i have New problem, suEXEC is not working, whcms couldn't write templates_c :
    if i switch to apache, it's work.

    already change external aplication from
     
    Last edited by a moderator: Jan 25, 2013
  6. webizen

    webizen Well-Known Member

    As it suggested, "The templates compiling directory '/home/xxx/xxx/templates_c/' must be writeable (CHMOD 777) before you can continue".
     
  7. asep

    asep New Member

    already chmod 777 but still error.
    If i switch to Apache, it is working.
     
  8. webizen

    webizen Well-Known Member

    pls pm the temp ssh root access.
     
  9. webizen

    webizen Well-Known Member

  10. asep

    asep New Member

Share This Page