[solved] LiteSpeed conversion broke sites.

Discussion in 'Install/Configuration' started by Licensecart, Jul 7, 2014.

  1. mistwang

    mistwang LiteSpeed Staff

    It does not have mysql_config, you need to check other rpms to locate it.
    check "mysql" and "mysql-libs"
  2. Licensecart

    Licensecart Well-Known Member

    I only see the usr/bin/ and /usr/lib64/mysql/mysql_config
  3. mistwang

    mistwang LiteSpeed Staff

    yes "/usr" should be used, if /usr/bin/mysql_config does not exist, you need to reinstall mysql rpm.
  4. Licensecart

    Licensecart Well-Known Member

    Hello mate so we're back to the one after you said to try /usr because /usr/bin/mysql_config is there and when i nano /usr/bin/mysql_config it it had some random symbols so there's something in it :).

    We got this after using the /usr command:

    we're using the remi repo and apache works fine. would it be because InterWorx uses two mysqls one for InterWorx and one for customers?
  5. mistwang

    mistwang LiteSpeed Staff

    Licensecart likes this.
  6. Licensecart

    Licensecart Well-Known Member

    Thank you mate, didn't know there was docs on it :) used to cPanel installs where you just click a button, can you please tell me where the litespeed php.ini is so we can add a few modules to it?
  7. mistwang

    mistwang LiteSpeed Staff

    it is in phpinfo() output.
  8. Licensecart

    Licensecart Well-Known Member

    oh, also we've fixed the issues but now we've got a issue with a jpg files having a litespeed 403 error, even though GD is set up:

  9. NiteWave

    NiteWave Administrator

  10. Licensecart

    Licensecart Well-Known Member

    I rebuild again using:
    And the images still don't load just a 403. It's a pain in the ass and very annoying... roll on a InterWorx Litespeed plugin :l


    But others work fine .jpeg

  11. Peter

    Peter Member

    Dear litespeed admin!

    Please solve our problem :)

    Ask for acces then solve the problem. Not reply-will it work?-reply-will it work? Will it blend maybe?

    So then please ask for acces then solve the problem. Thank you


    I hope you understand.. as maybe you are in the hosting industry for years.
    Last edited: Jul 9, 2014
  12. NiteWave

    NiteWave Administrator

    please check
    1)the permission of wp-content/uploads/2014/07/egy....jpg
    2)is php suExec enabled or not ?
    lsws web admin-> Server -> General -> PHP suEXEC: Yes or No ?
    or lsphp running as nobody or each account's username ?
    3) please check
    lsws web admin -> Server -> Security -> File Access
  13. Licensecart

    Licensecart Well-Known Member

    Perms: 0666 I tried chmoding to 644 (InterWorx file manager: cannot_chmod)

    Done via SSH and still didn't change.

    We have: Server > External App > Run On Start Up: suEXEC Daemon (would that be the issue?)

    PHP suEXEC: Yes
    PHP suEXEC Max Conn: 10

    File Access
    Follow Symbolic Link: Yes
    Check Symbolic Link: No
    Force Strict Ownership: Yes
    Required Permission Mask: 000
    Restricted Permission Mask: 000
    Script Restricted Permission Mask: 000
    Script Restricted Directory Permission Mask: 000

    Is this a litespeed issue or InterWorx?
  14. NiteWave

    NiteWave Administrator

    >Perms: 0666 I tried chmoding to 644 (InterWorx file manager: cannot_chmod)
    please check the parent directory's permission as well.
    assume lsphp5 running as user1, then ssh to the server as user1, it should be able to
    $cd /path/to/wp-content/uploads/2014/07
    $ls -l egy....jpg

    >Force Strict Ownership: Yes
    try: No
    Licensecart likes this.
  15. Licensecart

    Licensecart Well-Known Member

    Mate thank you, you've saved a customer leaving litespeed :) that Force Strict Ownership: No fixed the pictures :)

Share This Page