[solved] Litespeed Enterprise on CentOS 6.5, install_driver(mysql) failed

Discussion in 'CGI/Perl/Python' started by matthewUS, Dec 17, 2013.

  1. matthewUS

    matthewUS New Member


    Using Litespeed Enterprise on CentOS 6.5 (Vanilla, not external repo, official repo). The only external repo is MariaDB. Install done using official MariaDB docs and official MariaDB RPMs for CentOS.

    MariaDB works well with PHP apps but there are problems with CGI Apps. I have this output from a script:

    install_driver(mysql) failed: Can't locate DBD/mysql.pm in @INC (@INC contains: Plugins Modules . /usr/local/lib/perl5 /usr/local/share/perl5 /usr/lib/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5 /usr/share/perl5) at (eval 5) line 3.
    Perhaps the DBD::mysql perl module hasn't been fully installed,
    or perhaps the capitalisation of 'mysql' isn't right.
    I assume there's something wrong with MariaDB + Litespeed + CGI Apps (not Litespeed fault, i think 99.999% mariaDB fault). According your experience is it possibile to solve this problem doing compile php again with some "magic flags" ? If yes, how to use the flags to specify mariadb position ? :)

    Last edited by a moderator: Dec 18, 2013
  2. NiteWave

    NiteWave Administrator

    how about
    yum install perl-DBD-mysql
  3. matthewUS

    matthewUS New Member

    Problem Solved

    thank you very much, you saved me from a CentOS reinstall.
    In fact, the only thing I need is to download what you suggested.

    Thanks. Thanks. THanks. Problem Solved :)

Share This Page