[solved] LiteSpeed lsphp WordPress problem

Discussion in 'Install/Configuration' started by thehelpdesk, Jul 11, 2012.

  1. thehelpdesk

    thehelpdesk Member

    We've tried to enable LiteSpeed to work with WordPress but PHP continues to execute PHP as nobody or root despite setting changes. We cannot just chown nobody all the files as the server is setup for multiple users and domains. Further, the WordPress automatic upgrades are adamantly requested.

    We have Server > General > PHP suEXEC set to Yes.

    We have a custom LS Virtual Host setup for the domain with it's own ExtApp. Under the VH > Basic > ExtApp Set UID Mode is set to DocRoot UID, ExtApp Chroot Mode is set to Virtual Host Root.

    Under VH > ExtApp > we have a LSAPI App specified with it's own name devlog_lsphp5. Under those ExtApp settings an suEXEC User and suEXEC Group is specified and matches the user's system login. All files and directories are owned by the user.

    When running "ps -ef|grep devlog_lsphp5" it shows:
    root 7929 2947 0 16:19 pts/1 00:00:00 grep devlog_php5

    When running "ps -ef|grep lsphp5" for the main server, it shows:
    nobody 7760 7758 0 16:15 ? 00:00:00 lsphp5
    nobody 7761 7760 0 16:15 ? 00:00:01 lsphp5
    nobody 7792 7759 0 16:15 ? 00:00:00 lsphp5
    nobody 7793 7792 0 16:15 ? 00:00:00 lsphp5
    nobody 7794 7756 0 16:15 ? 00:00:00 lsphp5
    nobody 8081 7794 0 16:24 ? 00:00:00 lsphp5
    root 8111 2947 0 16:25 pts/1 00:00:00 grep lsphp5

    The WordPress automatic upgrade or using the file editor does not work unless the file is chmod 777 or chmod nobody.

    Based on all the forum postings is appears that PHP should be running as the specified user but it's not.
    Last edited by a moderator: Jul 12, 2012
  2. thehelpdesk

    thehelpdesk Member

    [Solved] Script Handler pointed to wrong LSAPI

    For all those that have struggled with Wordpress and LiteSpeed, the problem was solved by correcting the Script Handler on the Virtual Host to point to the correct LSAPI. It was mistakenly pointed to the server LSAPI.

    Go to VH > Script Handler > then Edit or Add a suffix for php pointing to the correct LSAPI.

Share This Page