[solved] LiteSpeed PHP permissions conflict

Discussion in 'Install/Configuration' started by P1X3, Aug 21, 2013.

  1. P1X3

    P1X3 New Member

    I have setup a virtual host in user's "domain.com" home directory and installed wordpress. Everything works great with permissions 775.

    Now the problem is wordpress can't automatically install plugins, themes, or perform any modifications to files at all. I looked at similar posts and people suggest that php is running as a user that doesn't have access to folder.

    I think this can be solved if I allow user that is running php to access wordpress root location. But how do I find what user is running php? In litespeed admin panel server is running as nobody, so does that mean that php is running as nobody as well? If that is the case then I might have to upgrade litespeed to change run-as user.

    Setting permissions of a folder that wordpress works with to 0777 solves the issue, however I would rather not have any 0777 files&folders.
    Last edited by a moderator: Aug 22, 2013
  2. NiteWave

    NiteWave Administrator

    ps -ef |grep lsphp
    to find which user run lsphp

    yes, you can configure litespeed to have lsphp run as which user/group.
  3. P1X3

    P1X3 New Member

    I see. Thank you for fast support. I had to change run-as user.

    I noticed a minor problem or maybe just small inconvenience.
    I tried upgrade option with a hope that it would let me enter run-as user, but unfortunately it did not.
    So I had to select re-install which then allowed me to enter run-as user, yet configurations were reset in the progress.
    Running install.sh as sudo/root.
  4. NiteWave

    NiteWave Administrator

    no need re-install.

    just set it:
    admin console->Server->External App->lsphp5->
    suEXEC User
    suEXEC Group

    then restart litespeed
  5. P1X3

    P1X3 New Member

    Thank you. I didn't see this when skimming through options.

Share This Page