[solved] LSLB Rewrite doesn't work

Discussion in 'General' started by dihuta, Dec 18, 2011.

  1. dihuta

    dihuta Well-Known Member


    Today I try to use Rewrite feature of LSLB but it doesn't work.
    Here what I try:

    Virtual Host -> my virtual host -> Rewrite
    - Enable Rewrite to Yes
    - Rewrite rules to test

    The I try www.mydomain.com/test.rss
    Nothing happen, page not found. This rule works fine if I put it in .htaccess of a node.

    Please help me to use it.
    Thank you.
    Last edited by a moderator: Dec 18, 2011
  2. NiteWave

    NiteWave Administrator

  3. dihuta

    dihuta Well-Known Member

    Working fine now.
    Thank you.
  4. dihuta

    dihuta Well-Known Member

    Another issue was solved.
    Thank you.
    Last edited: Dec 24, 2011
  5. dihuta

    dihuta Well-Known Member

    Help me to move Rewrite rules of VBSEO to LSLB rewrite


    I moved all my rewrite rules to LSLB Rewrite, but I can not make VBSEO Rewrite rules to work.

    Here it is:

    RewriteBase /

    ### VBSEO
    RewriteRule ^((urllist|sitemap_).*\.(xml|txt)(\.gz)?)$ vbseo_sitemap/vbseo_getsitemap.php?sitemap=$[L]

    RewriteCond %{REQUEST_URI} !(admincp/|modcp/|db/|cron|vbseo_sitemap)
    RewriteRule ^((archive/)?(.*\.php(/.*)?))$ vbseo.php [L,QSA]

    RewriteCond %{REQUEST_FILENAME} !-f
    %{REQUEST_FILENAME} !/(admincp|clientscript|cpstyles|images)/
    RewriteRule ^(.+)$ vbseo.php [QSA]
    Could you please help me make this work?
    Thank you so much.
  6. webizen

    webizen Well-Known Member

    in LSLB rewrite (just like rewrite in httpd.conf),

    RewriteRule ^(...)$

    should be

    RewriteRule ^/(...)$
  7. dihuta

    dihuta Well-Known Member

    I try this, but it doesn't work. All pages was displayed in blank

  8. webizen

    webizen Well-Known Member

    enable rewrite logging (LogLevel -> 9) to troubleshoot.

Share This Page