[solved] Lsphp5 + mcrypt

Discussion in 'General' started by frederichoule, Sep 30, 2012.

  1. frederichoule

    frederichoule Member

    Hello all, just wanted to know if anybody experienced this problem:

    I use EasyApache to rebuild php with MCRYPT enabled.
    Packages libmcrypt, libmcrypt-devel are installed
    As soon as the compile is done, none of my .php files on the server answers.
    Only the .html.

    Looks like PHP is hanging.

    I checked the error logs a bit everywhere, didn't see any error, neither in the LiteSpeed admin.

    What can I do?
    Last edited by a moderator: Oct 2, 2012
  2. NiteWave

    NiteWave Administrator

    check if it works under apache ?
  3. frederichoule

    frederichoule Member

    Just found this:

    [STDERR] lsphp5: error while loading shared libraries: libaspell.so.15: cannot open shared object file: No such file or directory

    Each time I try to add a module (mcrypt, aspell), I get this error.

    Any idea what I should do?

    Tried to symlink those from /usr/lib64/ to /usr/lib/, but doesn't work.
  4. frederichoule

    frederichoule Member

    PHP works flawlessly in console mode, even the mcrypt module works. It just doesn't work in LiteSpeed.
  5. frederichoule

    frederichoule Member

    Whoa! Forget to rebuild the CageFS. Now works flawlessly. Sorry! Thanks.

Share This Page