[solved] PHP.ini Files

Discussion in 'Install/Configuration' started by craigles, Feb 22, 2012.

  1. craigles

    craigles Active Member

    Hi Everyone,

    Hoping somebody can point me in the right direction with this query.

    I'm looking at replacing our fleet with Litespeed instead of Apache, but I've hit a roadblock for me.

    Basically, on our current setup when a user creates a custom php.ini in their home directory, php reads that as well as the master php.ini.

    It seems I can't make the same thing happen with Litespeed.

    Basically, when I run a phpinfo on Litespeed with a custom php.ini, it's not bringing in all the extensions as well. Whereas that is what it's currently doing on our existing setup.

    Things like FFMPEG, uploadprogress, memcache, suhosin, etc....

    Does anybody have any idea?

    Last edited by a moderator: Feb 23, 2012
  2. NiteWave

    NiteWave Administrator

  3. craigles

    craigles Active Member

    I've been staring at that particular link all day long and have tried any number of options to make it work and it's not working that way at all.

    If I use PHPRC=$VH_ROOT/public_html (option1) then it seems to load both master and local php.ini files, however NONE of the extensions show up at all ina phpinfo command.

    If I use PHP_INI_SCAN_DIR=$VH_ROOT/public_html (option2) then it does the same thing.

    However, if none of the above are mentioned in the environmental vars for php then the master php.ini loads WITH extensions.
  4. webizen

    webizen Well-Known Member

    Option 1 is for local php.ini only. Option 2 is local php.ini on top of master ini. Pls verify them with phpinfo page (check field "Loaded Configuration File" and "Additional .ini files parsed" ).
  5. craigles

    craigles Active Member

    Thanks for the info.

    I just decided to completely clear them all out, apply changed and graceful restart then added option2 back in and did the same again and it seems to be working fine now.

    Maybe with all my stuffing around I gave Litespeed a headache and it wasn't sure what it was doing.

    Anyway, thank's so much for your assistance - much appreciated :)


Share This Page