[solved] plugin cpanel from 11.36 error 500 during install

Discussion in 'Bug Reports' started by DoM, Mar 12, 2013.

  1. DoM

    DoM Well-Known Member

    From 11.36 cPanel does not provide perl anymore.

    You need to adjust your perl path to /usr/bin/perl inside:


    instead of /usr/local/bin/perl for new installation on fresh CentOS.

    Best regards
    Last edited by a moderator: Sep 11, 2013
  2. webizen

    webizen Well-Known Member

    try create a symlink /usr/local/bin/perl => /usr/bin/perl
  3. DoM

    DoM Well-Known Member

    I already fix it.

    I would like to just notify you this change.

  4. Vic Oakle

    Vic Oakle New Member

    how to create sysmlink? :confused:
  5. DraCoola

    DraCoola Well-Known Member

    some of my servers got the same error 500, but some are fine.
    to fix that perl error just reinstall all perl modules via the command line by running this command :

    /scripts/perlinstaller Task::Cpanel::Core
    i already did that and now feel very happy :)
  6. Vic Oakle

    Vic Oakle New Member

    root@xxx [~]# /scripts/perlinstaller Task::Cpanel::Core
    -bash: /scripts/perlinstaller: /usr/bin/perl: bad interpreter: No such file or directory

    how? :rolleyes:
  7. DraCoola

    DraCoola Well-Known Member

    seems like you don't have /usr/bin/perl at all?
    perhaps you could try just one from both above answers:

    1. edit /usr/local/cpanel/whostmgr/docroot/cgi/addon_lsws.cgi to point to Cpanel perl

    replace :
    with :

    2. create perl symlink

    ln -s /usr/local/cpanel/3rdparty/bin/perl /usr/bin/perl
  8. DraCoola

    DraCoola Well-Known Member

    Last edited: Sep 6, 2013
  9. NiteWave

    NiteWave Administrator

    Thank you DraCoola, save lots of our time!
  10. DraCoola

    DraCoola Well-Known Member

    you are welcome, NiteWave [​IMG]
  11. NiteWave

    NiteWave Administrator

    update: a user still experience 500 error after following above instruction.

    when run addon_lsws.cgi directly on command line:
    -bash: /usr/local/cpanel/whostmgr/docroot/cgi/addon_lsws.cgi: /usr/local/cpanel/3rdparty/bin/perl^M: bad interpreter: No such file or directory

    so the addon_lsws.cgi is in MS-DOS text format!

    after run
    #dos2unix /usr/local/cpanel/whostmgr/docroot/cgi/addon_lsws.cgi

    500 error finally gone and WHM lsws plugin installed with success
  12. mistwang

    mistwang LiteSpeed Staff

    looks like the file was uploaded in wrong way, the original file does not have "^M".

Share This Page