[Solved] Removing X-Turbo-Charged-By header

#1
Hi everybody,

I have searched the internet and could not find any solution to remove X-Turbo-Charged-By header. How can I remove it? I dont want to show Litespeed header.

I tried both php "header_remove" and htaccess functions but no luck.
 
Last edited by a moderator:
#3
Yes, I am using Cloudflare but it does not make sense. Anyway, I focued on "Cloudflare Workers" and did trick, able to remove any header I want...

Thanks
 

Pong

Well-Known Member
Staff member
#4
In LSWS Admin Console -> Server-> General -> General Settings -> Server Signature -> Select "Hide Full Header" should hide that header too.
 
#14
@serpent_driver, thanks but that isn't clear. It appears to be a setting within Litespeed as per the previous reply from Pong "In LSWS Admin Console -> Server-> General -> General Settings -> Server Signature -> Select "Hide Full Header" should hide that header too. "
 
#15
Again, LiteSpeed Enterprise doesn't add "X-Turbo-Charged-By" header and there is no setting in WebAdmin console to disable or enable it. In WebAdmin you can only control if Server header should appear or not. This setting is what @Pong already noticed.

If you have header "X-Turbo-Charged-By" then you have no origin installation of LiteSpeed Enterprise or you have OpenLiteSpeed, Cloudflare or other proxy running. To verify it check php_info and look for "$_SERVER['SERVER_SOFTWARE'] ".
 
#17
If you are on shared hosting ask your provider if your host uses a CDN like Cloudflare or a proxy.
If nothing helps try to overwrite this header in .htaccess

Code:
header add X-Turbo-Charged-By "Name of your choice"
 
Last edited:
Top