SOLVED | SMTP Configuration | Proudly powered by litespeed web server please be advised that litespeed technologies inc. is not a we hosting company"


New Member
Hi everyone,
I've try to setup my wordpress website's SMTP settings with Post SMTP plugin. After I start the setup wizard, I've entered the mail adress I would like to send mail as, I've seen an error message like :

"Proudly powered by litespeed web server please be advised that litespeed technologies inc. is not a we hosting company.."


After I press OK, I've seen that loading bar like this, forever...


We are using Microsoft 365 for email adress, I've already talked with IT but they said that everything looks good.
I've checked with SMTP tools ( and they already cheched everything with Powershell.

So, I'm not sure where is the problem, how can I fix it. I've tried with 2 other SMTP plug-in but non of them works. This is the only one shows error window.


Well-Known Member
This is just a part of a default message.
Better copy all html code and paste it in Text Mode in WpEditor. Then switch to Visual to understand what's relevant about that error.
What is your php version, and do you use an admin panel? There are various settings for admin side.


New Member
Hi Germont,
Current PHP version is 7.3.

I couldn't copy all html code, It's not allowed to do anything on window. I use cPanel to check settings but the thing is, I'm not an expert to use :/ I don't know what to check to find problem. Even I find the problem, I'm not sure I can fix with my low level of knowledge about this issue...
Do you think that it's about PHP version?


New Member
By the way, I use these pluings in Wordpress:

Advanced Post Block
All-in-One WP Migration
Colorlib 404 Customizer
Import/Export Customizer Settings
Starter Templates
WebP Converter for Media
Wordfence Security
Wordpress Importer
WP File Manager
WPForms Lite
Yoast Duplicate Post
Yoast SEO

They are all active now. Do you think that any of them cause an issue about SMTP settings?


Well-Known Member
Hard to tell without having all information.
I would check also error logs, there is one in public_html, other in wp-admin.
For a change give it a try with php7.4 /php8.