[solved] ssi echo encoding

Discussion in 'General' started by Javarome, Nov 21, 2012.

  1. Javarome

    Javarome New Member


    Not sure that this is a bug, so I'm posting in this 'General' category.

    I am setting a custom variable to contain some HTML code, like below (a link to "1969" with the last '9' excluded from the link in this example):

    <!--#set var="h1" value="<a href=\"..\">196</a>9" -->

    then just the line below I'm including a sub-file that is intended to use it:

    <!--#include virtual="/header.html" -->

    and finally, the header.html code is intended to display such a value:

    <!--#echo encoding="none" var="h1" -->

    Unfortunately, the result of the inclusion lead to the value interpreted as if the default "entity" encoding could not be changed :

    &lt;a href=\&quot;..\&quot;&gt;196&lt;/a&gt;9

    Apparently, this should have worked on Apache.
    What could I've done wrong?

    Thanks for your help.
    Last edited by a moderator: Nov 22, 2012
  2. mistwang

    mistwang LiteSpeed Staff

    that's indeed a bug in SSI processing.
    Please upgrade to the latest 4.2.1 build:

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.1
  3. Javarome

    Javarome New Member

    Thank you mistwang.
    Now I need to convince my web hosting provider to upgrade your software ;)

Share This Page