[solved] SSI Issue

Discussion in 'General' started by Elik, Dec 15, 2010.

  1. Elik

    Elik Member


    I am trying to figure out the issue with the SSI for one particular account here, which I get this errors as shown:

    2010-12-15 15:46:29.299 [INFO] [] Server Side Include is disabled for [/home/chennaih/public_html/], deny access.
    2010-12-15 15:46:29.299 [INFO] [] File not found [/home/chennaih/public_html/403.shtml]
    2010-12-15 15:47:11.857 [INFO] [] Server Side Include is disabled for [/home/chennaih/public_html/], deny access.
    2010-12-15 15:47:11.857 [INFO] [] File not found [/home/chennaih/public_html/403.shtml]

    Just he have .html set as SSI, so I set the proper handler for it which is as follows:

    Addtype application/x-httpd-shtml html

    But it seems it is not processing it, and the directory permissions seems correct for it. So what am I missing here?
    Last edited by a moderator: Dec 16, 2010
  2. webizen

    webizen Well-Known Member


  3. Elik

    Elik Member

    I beg to differ, since it is still support. Look at the other topic on that SSI part, which it is stated that it is supported, and it was working on the other server with Litespeed. Just something is off with this, and if you look at the logs, it shows that.


    It clearly states that SSI is supported, so I appreciate that someone is more knowledgable give some assistance on this?
    Last edited: Dec 15, 2010
  4. Elik

    Elik Member


    Okay...finally got it figured out. It is due to the new addition in cPanel, which they added the IncludesNoExec option in it, which in turn disables the SSI. Came across that gem while digging though the cPanel's code to see what got changed since the last time I dug though it.

    Now it works properly as it should be.
  5. webizen

    webizen Well-Known Member

    Thanks. We will update our faq page.

Share This Page