[solved] virtual host document root error

Discussion in 'Install/Configuration' started by cac, May 25, 2011.

  1. cac

    cac New Member


    Trying to set up virtual host Document Root directory in Configuration -> Virtual Hosts -> [name of our virtual host] -> General -> Document Root. When we specify /home/httpd/htdocs/domain-name, and click Save, the admin interface gives an error '*path /home/httpd/htdocs/domain-name does not exist. Please create manually.' Even though we've verified the path certainly does exist. It's currently owned by user 'httpd'.

    We've tried adding the lsadm user to the http group, still no luck. Do we need to create a directory that's owned by lsadm? Litespeed server process currently running as 'user(httpd) : group(httpd)'. So we're not sure why it wouldn't be able to read this directory.


    Attached Files:

    Last edited by a moderator: May 26, 2011
  2. webizen

    webizen Well-Known Member

    pls paste here the result of 'ls -ld /home/httpd/htdocs' and 'ls -ld /home/httpd/htdocs/domain-name'
  3. cac

    cac New Member

    [root@web15 ~]# ls -ld /home/httpd/htdocs
    lrwxrwxrwx 1 root root 16 Nov 30 17:47 /home/httpd/htdocs -> /sandbox/htdocs/
    [root@web15 ~]# ls -ld /home/httpd/htdocs/
    dr-xrwx--- 5 httpd ftp 4096 May 25 16:39 /home/httpd/htdocs/

    [root@web15 ~]# ls -ld /home/httpd/htdocs/domain-name
    dr-xrwxr-x 81 httpd ftp 20480 May 20 14:50 /home/httpd/htdocs/domain-name
  4. webizen

    webizen Well-Known Member

    do either of the followings:

    1. add lsadm to ftp group
    2. change group ownership of /sandbox/htdocs/ to httpd
    Last edited: May 26, 2011
  5. cac

    cac New Member

    Thanks! That seems to have fixed the issue.

Share This Page