Symlink not match?

Discussion in 'Bug Reports' started by kolorafa, Oct 15, 2009.

  1. kolorafa

    kolorafa Member

    lrwxrwxrwx 1 root root 12 Oct 15 14:11 htdocs -> soteshop/web


    2009-10-15 14:24:03.239 [ERROR] [config:vhost:xxxxx] Path of document root contains symbolic link or ownership does n
    ot match:/var/www/virtual/xxxxx/sotesh/p/web/

    x86_64 GNU/Linux

    4.0.10 Std

    Just that from nowhere is start to read htdocs ->soteshop/web links wrong

    and i have 2 domains with symlinks and it on both write the same error, the worse is that it come from nowhere, why can litespeed read wrong symlinks?
    Maybe its realted with that "sotesh" has the same lenght as "htdocs" and ls adds / ? but why from nowhere?
    Last edited: Oct 15, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    You have to allow symbolic link in your LSWS configuration.
    Only the error message uses a wrong path, the wrong path is due to failed symbolic check, when it passes, there is no problem.
  3. kolorafa

    kolorafa Member

    But its weird, i didn't change a bit and it suddenly blocked, i found that if i change Follow sym from owner match to Yes it works, but why it doesn't work with "If Owner Match" while it worked before .. hmm

    Is that normal that on owner match it may not work?

    Follow Symbolic Link Yes
    Check Symbolic Link No

    Follow Symbolic Link If Owner Match
    Enable Scripts/ExtApps Yes
    ExtApp Set UID Mode DocRoot UID

    ls -l /var/www/virtual/
    drwxrwx--- 11 vu2026 www-data 4096 paź 15 00:19 xxxx

    ls -l /var/www/virtual/xxxx
    lrwxrwxrwx 1 root root 12 wrz 14 12:13 htdocs -> soteshop/web
    drwxr-xr-x 17 vu2026 vu2026 4096 paź 3 21:38 soteshop

    ls -l /var/www/virtual/xxxx/soteshop
    drwxrwxr-x 20 vu2026 vu2026 4096 paź 7 19:38 web

Share This Page