vBulletin + Tapatalk not working on Litespeed Enterprise v4.0.18

Discussion in 'General' started by Bossman, Jan 12, 2011.

  1. Bossman

    Bossman Member


    We have just installed the trial version of Litespeed Web Server Enterprise v4.0.18 on our forums, but despite the obvious increase in performance, it seems to have broken the vBulletin Tapatalk plugin used by our iPhone / HTC users.

    Basically, the installation verifier from the Tapatalk site gives the following error:

    "Not Installed: Cannot detect /mobiquo/mobiquo.php. Check this file existence and try again."

    And sure enough, the direct link to said php file gives a 404 Page, even though it is there where it should be. The weird part is that a .js file (tapatalkdetect.js) located in the same folder can be accessed without issues :confused:

    There were no changes made to the htaccess file, firewall or folder structure when we switched from Apache to Litespeed, so the only conclusion we've drawn is that there's something in the Litespeed config which is "blocking" the access.

    Any suggestions on how we could solve this particular issue would be very appreciated.
  2. NiteWave

    NiteWave Administrator

    please compare the phpinfo() in litespeed and apache if any difference.

    google "mobiquo/mobiquo.php", there are a lot same error reports. here's one:

    it should not be a litespeed specific issue at all.
  3. Bossman

    Bossman Member

    We know about the common errors with mobiquo, but the plugin was working fine with Apache for months up until the switch, and as I've already said

    So that either leaves the PHP (which we will check) or the httpd server.
  4. NiteWave

    NiteWave Administrator

    so the question may be at "Building matching PHP" and I asked you to compare the output of phpinfo() under apache and litespeed. What's the environment and how did you build lsphp5 to match apache PHP.
  5. Bossman

    Bossman Member

    Ironically, it wasn't the PHP or Litespeed, but a meager owner permission on the docroot. My apologies for not thoroughly verifying everything before pointing fingers.

    On a related note, we keep getting quite a number of "Failed to initialize VMemBuf." errors in our logs, and the users have complained that on occassion, when they try to open an attachment, they would get a 503 error.

    Any particular tuning settings we should be aware of?

    The machine sports an Intel Xeon E5420 (2.5Ghz) with 16GB Ram, Raid1 for the filesystem / vbulletin php files and Raid10 for attachments.
  6. NiteWave

    NiteWave Administrator

    Thanks for the update. so the initial issue has gone?

    is the attachment big? there are many reasons which cause 503 error. no enough memory is one of them. what's "Memory Soft/Hard Limit" of your lsphp5 process?
  7. Bossman

    Bossman Member

    450M for the Soft Limit, 500M for Hard

    The maximum size for an attachment is 4.8MB, usually images.
  8. NiteWave

    NiteWave Administrator

    please try increase to 700M/750M, see if difference.
  9. Bossman

    Bossman Member

    It alleviated the problem to a certain degree, but users still get the 503 error from time to time.
  10. NiteWave

    NiteWave Administrator

    please check the related log message in error_log(or error.log) and stderr.log
  11. Bossman

    Bossman Member

    After a bit of tweaking we finally managed to get rid of the 503 Error and would like to purchase a license, since the trial key expires tomorrow, however, there's something we don't quite understand regarding the way Litespeed treats CPU cores:

    According to this thread, the trial version runs a 2-CPU license, which would mean that Litespeed only uses 2 of our 4 cores (as explained in the same thread).

    However, when looking at our HTOP output, we're seeing that all 4 CPU cores are constantly at 75%+ usage (keep in mind that this machine is used only for serving PHP and attachment files, there's no SQL or other services on it).

    So the question is:

    What would be the point of purchasing a 4-CPU license instead of a 2-CPU one, as the latter runs very well and seems to use all 4 cores anyway?
  12. mistwang

    mistwang LiteSpeed Staff

    When you serve pure static content and I/O wait is high, or serve a lot of HTTPS traffic, you should purchase the 4-CPU license. In those cases, LiteSpeed itself may consume a lot CPU or blocking at disk I/O system calls.

Share This Page