Virtual Host not accessible with correct password for security

Discussion in 'Install/Configuration' started by ppgengler, Jul 5, 2011.

  1. ppgengler

    ppgengler Member


    I have a RoR virtual host setup on LSWS 4.1.1 and if I enable security the site correctly prompts me for a username and password, but it will not accept any combination, including the correct ones. From the working, unprotected site I do these things:

    1) Goto Security tab for Virtual Host
    2) Add an Entry under the Realms List.
    2a) Select DB type of password file
    2b) Realm Name: Test Realm
    2c) User DB Location: $SERVER_ROOT/conf/$VH_NAME.htaccess
    2d) Save, then handle error by creating DB location file, Save again
    3) View 'Test Realm' realm and click on User DB Location
    4) Click Add for User DB Entries and add user with name of 'test', password of 'password', no groups
    5) Goto the Context tab for Virtual Host and click edit for the Rails context
    6) Under the Realm drop down select Test Realm
    7) Gracefully restart the server

    I have other servers running 4.0.6 and I'm pretty sure I followed these same steps and it worked, but with 4.1.1 it won't accept the username/password no matter what. I've looked in error.log file and all it says is authentication failed.

    Are there any known issues with 4.1.1 and htaccess files? Is there anyway to get additional information? Is there some way for me to test the username/password against the htaccess file directly to make sure that's right?

  2. MoonWolf

    MoonWolf New Member

    I had similar problem. Try put the .htpasswd file in same physical directory as the one being protected. that solved my problem.

    Good luck.
  3. mistwang

    mistwang LiteSpeed Staff

    Likely a file permission issue with .htpasswd file.

Share This Page