Weird AWStats problem

Discussion in 'General' started by Cloudmaster, Aug 31, 2009.

  1. Cloudmaster

    Cloudmaster Member

    Hi all,

    I've got AWStats working with Litespeed, but I'm trying to tweak a few AWStats options via the awstats.domain.conf file, namely to ignore hits from my IP, and set a GeoIP option. The problem is that although I've now set the conf file to read only, every time AWStats checks the logs (hourly in my case) it's re-writing the conf file (even though I set it to read only) & removing the options I set.

    Is there another conf file I should be editing?

    Thanks for looking
  2. Cloudmaster

    Cloudmaster Member

    I think I've got it solved by reading the relevant bit of the wiki :)
  3. MikeDVB

    MikeDVB Well-Known Member

    Which part of the wiki did you read? I would personally have set chattr +i on the file to prevent it from being modified.
  4. Cloudmaster

    Cloudmaster Member

    Didn't understand the option you suggested (never seen that terminology before). The file is chmod'd 444 but still manages to be overwritten (at least the timestamp changes every time AWStats is run)

    Here's the part of wiki that solved the problem, seems that some options are set from Litespeed, but others have to be set in awstats.model.conf
  5. MikeDVB

    MikeDVB Well-Known Member

  6. Cloudmaster

    Cloudmaster Member

    Thanks for the reply Mike, that option might be useful in the future. For my current needs, I think what's set out in the wiki is my best option, since if I set up any new domains on the box I'd still want to use the same setup that's now already set in awstats.model.conf, so all I need to set up are the relevant bits in the Litespeed GUI

Share This Page