Wordpress errors

Discussion in 'PHP' started by whey, Dec 7, 2008.

  1. whey

    whey Member

    I have LiteSpeed 3.3.22, PHP 5.2.6, MySql 5.x and Wordpress 2.6.5 successfully installed however, when I try to access my blog on anything but the administration side it gives me a 404 error.


    However the wordpress login and admin features are still avialable if typed in directly or as follows:


    I'm rather new to this so hopefully one of you guys can help me out, can't find much on the web.

  2. ffeingol

    ffeingol Well-Known Member

  3. whey

    whey Member

    (new to the whole programing/server side thing - sorry)

    In wordpress admin it says:

    If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file. Click in the field and press CTRL + a to select all.

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    However I am not sure how to edit or even find .htaccess, tried editing it in the litespeed pannel but I could only find a allow overright option in configure/server. I am not used to litespeed or apache either.

    I do however have root access to my server (using debian). If you could give me instructions on how to access the htaccess that would be appreciated.

    Sorry for not knowing the basics :) Thanks for the help!

    Last edited: Dec 8, 2008
  4. ffeingol

    ffeingol Well-Known Member

    This is not a LSWS issue, it's a WP setup issue :D

    Just copy that code and put it in a file called .htaccess in the root of the web site. That should resolve the problem.
  5. whey

    whey Member

    Tried that, there was no .htaccess file at the root the the site so I created one and placed it in in the root of the website (usr/local/lsws/DEFAULT/html/.htaccess). Still got the same error even after both a web server and server reboot.

  6. mistwang

    mistwang LiteSpeed Staff

  7. whey

    whey Member

    got it, thanks guys. will let you know how it pans out.

  8. whey

    whey Member

    Having another error (had to reinstall the webserver). now the site is just giving me the "Your PHP installation appears to be missing the MySQL" error.

    I fixed this last time with something like '--with-mysql' but I forget what to do.
  9. kuts

    kuts Well-Known Member

    build php via LiteSpeed panel with '--with-mysql'


    ./configure '--with-mysql=/usr', etc. etc.
  10. whey

    whey Member



    Back to the same problem as the initial part of the post. But my virtual host won't allow me to make changes (ie enable htaccess and audo indexing).

    Why would this be? Did not happen the last time. (ie. none of these properties can change)

    Last edited: Dec 19, 2008

Share This Page