Xcache suddendly don't work anymore

Discussion in 'Install/Configuration' started by webmastergreg, Nov 14, 2013.

  1. webmastergreg

    webmastergreg Member

    Hello all

    Here you are the little story

    I'm on whm with litespeed plugin, all is fine

    PHP 5.3.27 compiled ok with easy apache and compiled fine too for LS.

    I'm using Xcache 3.0.3 all works perfect with apache.

    So I've set the worker group for LS under the pre-virtualhost with this:
    <IfModule LiteSpeed>
    LSPHP_ProcessGroup on
    LSPHP_Workers 15

    Everything still all ok

    Then I've put the suEXEC Daemon in the Web Console for the external app lsphp5 of LS

    Still all fine and Xcache at this time was all perfect because of each hosts separated for the use of the opcode.

    Then, Xcache told me that the memory allocated for the cache was not enough, so I decided to edit the php.ini, made the changes, the restart and so, no more xcache.

    Now when under litespeed, xcache diagnosis tab tell me this:

    Your PHP pages is not accelerated by XCache. Set xcache.cacher = On

    But when under apache all is ok.

    Already tried to recompile the match build for litespeed, but same issue.

    and now this is:
    Not loaded Add extension=xcache.so (or xcache.dll) in /usr/local/lib/php.ini (See above)

    But this is wrong, as all is ok under apache.

    Any idea/advice for this please ?

    Thanks a lot
    Last edited: Nov 14, 2013
  2. mistwang

    mistwang LiteSpeed Staff

  3. webmastergreg

    webmastergreg Member

    Thank you

    yes solved by the soft limit adjustment

Share This Page