Tested 3rd-Party Plugins and Themes

This is a list of known popular plugins and themes that we have checked for compatibility. All of the products listed here have passed the test and are compatible with LSCache. If this list looks small, it is because we only test those plugins that have the potential to conflict with a cache solution.

Many of these plugins/themes now work with LSCWP right out of the box, but others require some action before they will work. Please note the Action Required column.

Plugin Action Required Notes
WooCommerce The plugin caches the pages that WooCommerce deems cacheable.
WPML Separate cache copies are stored for each page for each language.
bbPress New forums/topics/replies will purge the relevant parent pages.
Contact Form 7 Purge cache after creating/editing a form. Set TTL to 24 hours (86400 seconds) or less.
Caldera FormsSet Enable ESI to ON in ESI SettingsForms are exempt from other cache rules on the site. v1.5.6.2+
Google XML Sitemaps
Yoast SEOPurge cache on activation/deactivation
Wordfence Security
NextGen Gallery Albums and galleries are purged accordingly when related images are updated.
ShortPixel
Aelia CurrencySwitcher Has a vary for the four required cookies.
Fast Velocity Minify
Autoptimize Will purge cache when its cache is purged.
Better WP Minify
WP TouchSet Cache Mobile to ON in Cache Settings
Theme My Login
wpForo
WPLister
WP-PostRatings
Login With Ajax
Ninja Forms
Post Types Order v1.9.3.6+
Theme Action Required Notes
Avada
Elegant Themes Divi v3.0.67+
BoomBox Viral Magazine WordPress Theme

My Favorite Plugin Isn't Listed

It's impossible to list every plugin that is compatible with LiteSpeed Cache, so here is a rule of thumb:

If the plugin doesn’t generate site content, or do anything out of the ordinary with existing front-end content, then chances are it is 100% compatible with LiteSpeed Cache for WordPress. (The vast majority of plugins fall into this category.)

Still note sure? Consider these points:

  • LSCWP purges pages from the cache when certain events are triggered. If the plugin generates content that triggers those same events, then it's compatible in that area.
  • LSCWP follows a set of rules to determine whether a page is cacheable. If the plugin generates content that also abides by those same rules, then it's compatible in that area.
  • If the plugin uses a nonce, customization may be required. Here's an example.

If you still are unsure, we've written this guide to testing for compatibility so you can check for yourself.

If you have the skills, take a look at our API and make the plugin compatible yourself!

 
litespeed_wiki/cache/lscwp/supported_plugins.txt · Last modified: 2018/11/07 16:12 by Lisa Clarke