Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
litespeed_wiki:config:mod_security_faq [2018/10/08 20:55]
Lisa Clarke [Unsupported Variable error] Proofreading
litespeed_wiki:config:mod_security_faq [2018/11/27 20:51]
Jackson Zhang [LSWS doesn't support "LocationMatch" directive]
Line 45: Line 45:
  
 The above error messages simply mean the given variables are not supported by LSWS yet. The errors can simply be ignored. We periodically review our mod_security engine and frequently add new support. Stay tuned.  ​ The above error messages simply mean the given variables are not supported by LSWS yet. The errors can simply be ignored. We periodically review our mod_security engine and frequently add new support. Stay tuned.  ​
 +
 +===== You should not place '​SecDebugLogLevel'​ inside "​LocationMatch"​ context =====
 +When you use '​SecDebugLogLevel',​ '​SecAuditLogParts'​ or '​SecAuditLog'​ within "​LocationMatch"​ directive, you may see the following error on LSWS:
 +  Directive '​SecDebugLogLevel'​ is not allowed in current context.
 +  Directive '​SecAuditLogParts'​ is not allowed in current context.
 +  Directive '​SecAuditLog'​ is not allowed in current context.
 +
 +LSWS does support "​LocationMatch"​ context but doesn'​t allow those three directives configured in it. Audit log is only set at server level, while debug log level can be set at vhost level. We have no plan to make it available at matching context level, which will be counterproductive to the optimization applied to the engine.
 
litespeed_wiki/config/mod_security_faq.txt · Last modified: 2018/11/27 21:22 by Lisa Clarke