Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
litespeed_wiki:licenses:upgrade-server-failed-with-license-error [2018/09/20 14:04]
Jackson Zhang [Update log may show the same error]
litespeed_wiki:licenses:upgrade-server-failed-with-license-error [2018/09/20 15:31] (current)
Lisa Clarke Proofreading
Line 1: Line 1:
-=====  ​How to fix "You are not authorized ​to use this binary"​ error? ​===== +====== Fixing LiteSpeed Web Server Update Errors ====== 
-If you tried to upgrade your LSWS version (/​usr/​local/​lsws/​admin/​misc/​lsup.sh -f) but failed with the license error: ​[ERROR] You are not authorized to use this binary, please purchase upgrades., try the following in the command line+=====  You Are Not Authorized ​to Use This Binary ​===== 
 +If you tried to upgrade your LSWS version (''​/​usr/​local/​lsws/​admin/​misc/​lsup.sh -f''​) but failed with the license error: ​''​[ERROR] You are not authorized to use this binary, please purchase upgrades.''​, try the following in the command line:
  
   /​usr/​local/​lsws/​admin/​misc/​lsup.sh -f -v <​version>​   /​usr/​local/​lsws/​admin/​misc/​lsup.sh -f -v <​version>​
   ​   ​
-If you are still getting a similar error, there is no need to panic. +If you are still getting a similar error, there is no need to panic. You most likely have an owned license with a one year free upgrade period that has recently expired. You will need to purchase a yearly upgrade ​if you want to use the latest version. Check [[litespeed_wiki:​licenses:​yearly-upgrade-for-owned-licenses|here]] for details.
- +
-You most likely have an owned license with a one year free upgrade period that has recently expired. You will now need to purchase a yearly upgrade ​to be able to use latest version. Check [[litespeed_wiki:​licenses:​yearly-upgrade-for-owned-licenses|here]] for details.+
  
 ===== Software Update Expiration ===== ===== Software Update Expiration =====
-When Software ​update ​expired, you may see the following message ​from LiteSpeed Admin Console. ​It could be the time for you to purchase a yearly upgrade ​addon.+When the software ​update ​expires, you may see the following message ​on the LiteSpeed Admin Console. ​This means it'​s ​time for you to purchase a yearly upgrade ​add-on, if you would like to continue getting updates.
  
   Software Update Expiration   Software Update Expiration
   Sep 01, 2018 Expired   Sep 01, 2018 Expired
  
-===== Software ​upgrade has expired ​===== +===== Software ​Upgrade Has Expired ​===== 
-When Software upgrade has expired, you may see the following message:+When the software update expires, you may see the following message:
  
   root@cpanel9 [~]# /​usr/​local/​lsws/​bin/​lshttpd -V   root@cpanel9 [~]# /​usr/​local/​lsws/​bin/​lshttpd -V
Line 21: Line 20:
   2018-09-20 12:​49:​44.739472 [NOTICE] Memory size is: 131735720KB.   2018-09-20 12:​49:​44.739472 [NOTICE] Memory size is: 131735720KB.
   ​   ​
-===== Update ​log may show the same error ===== +===== Error in Update ​Log ===== 
- +The update log may show the same error, if the upgrade ​to the latest build is not working:
-Upgrade ​to the latest build is not working:+
  
   root@cpanel9 [~]# tail /​usr/​local/​lsws/​autoupdate/​update.log   root@cpanel9 [~]# tail /​usr/​local/​lsws/​autoupdate/​update.log
  • Admin
  • Last modified: 2018/09/20 15:31
  • by Lisa Clarke