Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
litespeed_wiki:php:apt [2018/08/24 19:17]
Jackson Zhang [Installing PHP From The LiteSpeed Debian/Ubuntu Repository]
litespeed_wiki:php:apt [2019/07/25 19:25] (current)
Jonathan Kagan [Installation]
Line 1: Line 1:
 ====== Installing PHP From The LiteSpeed Debian/​Ubuntu Repository ====== ====== Installing PHP From The LiteSpeed Debian/​Ubuntu Repository ======
  
-For LSWS native and OpenLiteSpeed,​ Installing PHP with LiteSpeed SAPI from our repository is much faster and easier than compiling it yourself. If you are not used to compiling PHP you will likely find this method more comfortable. We currently maintain LiteSpeed PHP (LSPHP) for Debian 8 (Jessie), Debian 7 (Wheezy), Ubuntu 12.04 (Precise Pangolin), Ubuntu 14.04 (Trusty Tahr), Ubuntu 16.04 (Xenial Xerus) and Ubuntu 18.04 (Bionic Beaver) in this repository.+For LSWS native and OpenLiteSpeed,​ Installing PHP with LiteSpeed SAPI from our repository is much faster and easier than compiling it yourself. If you are not used to compiling PHP you will likely find this method more comfortable. We currently maintain LiteSpeed PHP (LSPHP) for Debian 10 (Buster), Debian 9 (Stretch), ​Debian 8 (Jessie), Debian 7 (Wheezy), Ubuntu 12.04 (Precise Pangolin), Ubuntu 14.04 (Trusty Tahr), Ubuntu 16.04 (Xenial Xerus) and Ubuntu 18.04 (Bionic Beaver) in this repository. As the Debian/​Ubuntu Operating Systems become EOL (End of Life) we will stop updating packages for those Operating Systems in this repository without notice.
  
 ===== Important Update for Debian Repository ===== ===== Important Update for Debian Repository =====
Line 35: Line 35:
 ===== Installation ​ ===== ===== Installation ​ =====
  
-  - Add the LiteSpeed Debian Repository with the following command: (You must have **wget** installed ) \\ \\  <​code>​wget -O - http://​rpms.litespeedtech.com/​debian/​enable_lst_debain_repo.sh | bash</​code>​+  - Add the LiteSpeed Debian Repository with the following command: (You must have **wget** installed ) \\ \\  <​code>​wget -O - http://​rpms.litespeedtech.com/​debian/​enable_lst_debian_repo.sh | bash</​code>​
   - Install LiteSpeed PHP with apt-get: \\ \\ <​code>​apt-get install lsphpXX (XX can be 54,​55,​56,​70,​71,​72)</​code>​   - Install LiteSpeed PHP with apt-get: \\ \\ <​code>​apt-get install lsphpXX (XX can be 54,​55,​56,​70,​71,​72)</​code>​
  
Line 44: Line 44:
 For example: ​ For example: ​
  
-  apt-get install ​lsphp56-gd lsphp56-mysql ​lsphp56-mcrypt lsphp56-imap+  apt-get install ​lsphp73 lsphp73-mysql ​lsphp73-pdo lsphp73-opcache
  
 Available packages can be checked using the following command: Available packages can be checked using the following command:
  • Admin
  • Last modified: 2018/08/24 19:17
  • by Jackson Zhang