Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
litespeed_wiki:php:apt [2019/07/25 19:25]
Jonathan Kagan [Installation]
litespeed_wiki:php:apt [2020/06/25 13:48] (current)
Lucas Rolff 20.04 and PHP 7.3/7.4
Line 1: Line 1:
 ====== Installing PHP From The LiteSpeed Debian/​Ubuntu Repository ====== ====== Installing PHP From The LiteSpeed Debian/​Ubuntu Repository ======
  
-For LSWS native and OpenLiteSpeed,​ Installing PHP with LiteSpeed SAPI from our repository is much faster and easier than compiling it yourself. If you are not used to compiling PHP you will likely find this method more comfortable. We currently maintain LiteSpeed PHP (LSPHP) for Debian 10 (Buster), Debian 9 (Stretch), Debian 8 (Jessie), Debian 7 (Wheezy), Ubuntu 12.04 (Precise Pangolin), Ubuntu 14.04 (Trusty Tahr), Ubuntu 16.04 (Xenial Xerus) ​and Ubuntu 18.04 (Bionic Beaver) in this repository. As the Debian/​Ubuntu Operating Systems become EOL (End of Life) we will stop updating packages for those Operating Systems in this repository without notice.+For LSWS native and OpenLiteSpeed,​ Installing PHP with LiteSpeed SAPI from our repository is much faster and easier than compiling it yourself. If you are not used to compiling PHP you will likely find this method more comfortable. We currently maintain LiteSpeed PHP (LSPHP) for Debian 10 (Buster), Debian 9 (Stretch), Debian 8 (Jessie), Debian 7 (Wheezy), Ubuntu 12.04 (Precise Pangolin), Ubuntu 14.04 (Trusty Tahr), Ubuntu 16.04 (Xenial Xerus)Ubuntu 18.04 (Bionic Beaver) and Ubuntu 20.04 (Focal Fossa) in this repository. As the Debian/​Ubuntu Operating Systems become EOL (End of Life) we will stop updating packages for those Operating Systems in this repository without notice.
  
 ===== Important Update for Debian Repository ===== ===== Important Update for Debian Repository =====
Line 36: Line 36:
  
   - Add the LiteSpeed Debian Repository with the following command: (You must have **wget** installed ) \\ \\  <​code>​wget -O - http://​rpms.litespeedtech.com/​debian/​enable_lst_debian_repo.sh | bash</​code>​   - Add the LiteSpeed Debian Repository with the following command: (You must have **wget** installed ) \\ \\  <​code>​wget -O - http://​rpms.litespeedtech.com/​debian/​enable_lst_debian_repo.sh | bash</​code>​
-  - Install LiteSpeed PHP with apt-get: \\ \\ <​code>​apt-get install lsphpXX (XX can be 54,​55,​56,​70,​71,​72)</​code>​+  - Install LiteSpeed PHP with apt-get: \\ \\ <​code>​apt-get install lsphpXX (XX can be 54,​55,​56,​70,​71,​72,73,74)</​code>​
  
 To install other php packages for lsphpXX: To install other php packages for lsphpXX:
Line 48: Line 48:
 Available packages can be checked using the following command: Available packages can be checked using the following command:
  
-  apt-cache search lsphpXX (XX can be 54,​55,​56,​70,​71,​72)+  apt-cache search lsphpXX (XX can be 54,​55,​56,​70,​71,​72,73,74)
 ===== About enable_lst_debain_repo.sh ===== ===== About enable_lst_debain_repo.sh =====
  
  • Admin
  • Last modified: 2019/07/25 19:25
  • by Jonathan Kagan