Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Last revision Both sides next revision
litespeed_wiki:php:lsapi-troubleshooting [2016/09/13 21:31]
Jackson Zhang [Preamble]
litespeed_wiki:php:lsapi-troubleshooting [2018/09/17 19:56]
Michael Alegre removed
Line 1: Line 1:
-====== LSWS PHP/LSAPI Build troubleshooting guide ======+====== LSWS PHP/LSAPI Build troubleshooting guide (Archive Only) ======
  
 ===== Preamble ===== ===== Preamble =====
-This document log error messages during the php build stage for LiteSpeed Web Server (LSWS) and their relevant fixes. The general PHP/LSAPI build procedures are described in  [[http://​www.litespeedtech.com/​support/​wiki/​doku.php?​id=litespeed_wiki:​php:​lsapi|PHP with LSAPI Compile/​Install How-To]]. As of this writing, the latest ​php 5.2.16 ​is out. The latest LSAPI is at version 5.5. We will use php 5.2.16 and LSAPI 5.5 as an example to build LSPHP.+The following is a list of common ​error messages ​encountered ​during the php build stage for LiteSpeed Web Server (LSWS) and their relevant fixes. The general PHP/LSAPI build procedures are described in [[http://​www.litespeedtech.com/​support/​wiki/​doku.php?​id=litespeed_wiki:​php:​lsapi|PHP with LSAPI Compile/​Install How-To]]. As of this writing, the latest ​PHP version is 5.2.16. The latest LSAPI released ​is version 5.5. We will use php 5.2.16 and LSAPI 5.5 as an example to build LSPHP.
  
-Please be aware that you may not need to build PHP by yourself ​anymore ​at most of the time(let's say 99%). When using control ​panel, it has pre-built RPM/APT packages. For non control panel user, you may use LiteSpeed repositories for CentOS/​Debian/​Ubuntu systems.  +In most cases, control panel users do not need to build PHP manually ​anymoremost of the time control ​panels have pre-built RPM/APT packages. For users not using a control panel, you may use the LiteSpeed repositories for CentOS/​Debian/​Ubuntu systems. ​
- +
-The followings are achieved documents , which may contain out of date information. PHP compiling is a general topic, not limited to LSWS,  hence you are free to "​google"​ your error message for solutions. Again, we recommend you to go through RPM/APT packages installation process instead of PHP compiling. Compiling PHP only when you have a "have to" reason.+
  
 +This list consists of archived documents which may contain out of date information but may also provide a good starting place in solving any errors you encounter while compiling PHP. PHP compilation is a general topic and is not limited to LSWS. If you do not find an answer here, you are free to "​google"​ your error message for solutions. Again, we recommend you to go through RPM/APT packages installation process instead of PHP compiling unless you have a "have to" reason to compile manually.
 ===== Procedures ===== ===== Procedures =====
 1. Pre-requisites 1. Pre-requisites
  • Admin
  • Last modified: 2018/09/17 19:56
  • by Michael Alegre