Troubleshoot Plesk “[ACL] Access to context [/] is denied!” error

Running Plesk and newly installed LiteSpeed. Main website running well but no access to subdomain Error log shows “[ACL] Access to context [/] is denied!”. What happened?

[ACL] Access to context [/] is denied! 

is caused by directives from mod_access_xxxx module, “Deny from …” .

Full investigation of Apache httpd.conf, included conf files or .htaccess file related to domain required.

LiteSpeed read Apache configuration file with “mod_php5,sapi_apache2,python,fcgid” Apache modules ignored.

/etc/httpd/conf/httpd.conf checked and no problem.

In /etc/httpd/conf/plesk.conf.d/horde.conf:

    <IfModule mod_fcgid.c>
        FcgidInitialEnv PP_CUSTOM_PHP_CGI_INDEX fastcgi
        FcgidInitialEnv PP_CUSTOM_PHP_INI "/etc/abcdef-webmail/horde/horde/php.ini"
        FcgidMaxRequestLen 134217728
        <Directory "/usr/share/psa-horde">
            <Files ~ (\.php$)>
                SetHandler fcgid-script
                FCGIWrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper .php
                Options +ExecCGI

            Order allow,deny
            Allow from all

Although there is a line “Allow from all” for that directory, it actually was ignored completely since mod_fcgid was black listed in “Apache Ignored Modules”.

Add the following:

<Directory "/usr/share/psa-horde">
Order allow,deny
Allow from all

outside of <IfModule mod_fcgid.c>…</IfModule> fixed the problem.

Plesk template may need to be customized or changed not to put everything inside <IfModule mod_fcgid.c> block. Alternatively try not to use fcgid as the default PHP handler.

litespeed_wiki/plesk/access-denied-errors.txt · Last modified: 2015/07/20 18:27 by Michael Alegre