Configuring cPanel EA4 + CloudLinux + LSWS to Use CloudLinux PHP Selector Instead of EA4 MultiPHP

If you use cPanel EA4 on a CloudLinux system, the LiteSpeed auto-installer script will add the proper external apps for both EA4 MultiPHP and CloudLinux PHP Selector automatically, when installing LSWS. PHP handlers will be set to use EA4 MultiPHP by default with version 5.6.

The following external apps are installed:

External app lsphp56:

External app cl_phpselector:

PHP Handlers:

The suffixes .php and .php5 will be handled by lsphp56 by default. If you want to use CloudLinux PHP Selector, you should change .php and .php5 to be handled by cl_phpselector.

Changing the Default

As you may know, when CloudLinux is integrated with cPanel Easy Apache 4, the CloudLinux PHP Selector will only be used if the cPanel MultiPHP version for a domain is the same as the cPanel system default PHP version, which was set from the very beginning. (See “Understanding How This Works” below for more information.)

For example, say the cPanel system PHP default version is ea-php56 for example1.com, and MultiPHP manager is set to ea-php56. Then cPanel will add the following to the .htaccess in example1.com's document root:

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php56” package as the default “PHP” programming language.
<IfModule mime_module>
 AddType application/x-httpd-ea-php56 .php .php5 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

So, what do you do if you want to use CL PHP Selector 7.0 (for example)?

It's important to understand how the CloudLinux PHP Selector works with cPanel EA4. In this case, you just need to check which CloudLinux PHP Selector is set for this account. If CL PHP Selector is set to native, then cPanel EA4 MultiPHP version is used. If a CL PHP Selector version other than native is used, then the web server will use the CL PHP Selector version chosen.

There's no need to worry about AddType application/x-httpd-ea-php56 in the .htaccess file. It will be overridden by the CloudLinux PHP Selector setting.

Run the following command to check example1 user:

/usr/bin/cl-selector --summary php --user example1
5.1 e - -
5.2 e - -
5.3 e - -
5.4 e - -
5.5 e - -
5.6 e - -
4.4 e - -
7.0 e - -
7.1 e - -
native e d s

You can set it to use CL PHP Selector 7.0 instead of native:

/usr/bin/cl-selector --select=php --version=7.0 --user example1

To verify:

/usr/bin/cl-selector --summary php --user example1
5.1 e - -
5.2 e - -
5.3 e - -
5.4 e - -
5.5 e - -
5.6 e - -
4.4 e - -
7.0 e - s
7.1 e - -
native e d -

Check the PHP Info page, and you should see CL PHP Selector 7.0 is in use.

Understanding How This Works

How does cPanel know whether to get the PHP version from .htaccess or from the CloudLinux PHP Selector?

A file search for .htaccess is performed in the current directory and in the parent directories. If the file is not found, then the system default PHP version is applied. The system default PHP version can be changed via the CloudLinux PHP Selector.

If .htaccess is found, then the following rules are applied to determine the PHP version:

  1. If CageFS is disabled, then the CL PHP Selector is not active and the PHP version from .htaccess is applied.
  2. If CageFS is enabled, then:
    1. If the PHP version specified in .htaccess differs from the ystem default, then the .htaccess version is applied.
    2. If the system default PHP version is specified in the .htaccess file, then the CL PHP Selector version is applied:
      1. If native is chosen in the CL PHP Selector, then the .htaccess PHP version is applied.
      2. If the PHP version chosen in the CL PHP Selector differs from native, then the CL PHP Selector version is applied.

Note: If you are using a version of cPanel prior to 11.56, please be aware that it does not support hooks for MultiPHP Manager. As a result, such changes are handled by cron job and come with up to a 10-minute delay.

For more on this, see the CloudLinux documentation.

alt-php within Multi-php Manager is not supported by LiteSpeed yet

In cPanel & WHM version 66 and later, EasyApache 4 allows you to use Vendor-provided PHP versions such as CloudLinux PHP selector right from MultiPHP Manager, such as alt-php44, alt-php51, alt-php52, alt-php53, alt-hpp54, alt-php55, alt-php56, alt-php70, alt-php71, they are not yet supported by LiteSpeed. Please continue to use ea-phpxx and follow the above steps to determine if CloudLinux PHP selector is used, but not directly from MultiPHP Manager.

 
litespeed_wiki/cpanel/use-cloudlinuxphpselector-on-ea4-with-lsws.txt · Last modified: 2017/11/13 21:28 by Jackson Zhang