4.0.2: 403 error for all static files

Discussion in 'Bug Reports' started by andreas, Apr 25, 2009.

  1. andreas

    andreas New Member

    Since the upgrade to 4.0.2, all static file request cause 403 errors.

    Switching back to 4.0 solves the problem.
  2. MindTooth

    MindTooth New Member

    With the guide of usefuljaja, I have a symlink for phpmyadmin at, but now I can't get phpMyAdmin to run.

    Birger :)
  3. gboudreau

    gboudreau Member

    Same thing here. 4.0.1 doesn't have this problem. Can't see anything in the log files.
  4. mistwang

    mistwang LiteSpeed Staff

  5. gboudreau

    gboudreau Member

    My VH_ROOTs are all something like:
    $SERVER_ROOT/www-html/xyz

    Where $SERVER_ROOT/www-html is a symlink to /var/www/html

    With "Restrained" enabled, requests to any VH with a VH_ROOT that contains a symlink return 403 because of that, but I don't think it should.
  6. mistwang

    mistwang LiteSpeed Staff

    If VH_ROOT is $SERVER_ROOT/www-html/xyz, the server will not serve anything beyond its vhost root.
    Your vhosts are configured natively, not through httpd.conf, right?
  7. gboudreau

    gboudreau Member

  8. MindTooth

    MindTooth New Member

    Where do you suggest I put phpMyAdmin then? A folder under $VH_ROOT?

    Birger :)
  9. mistwang

    mistwang LiteSpeed Staff

    Please download and try 4.0.3 release package. Just change the version number in the download link to get it.
    Should work better.
  10. MindTooth

    MindTooth New Member

    Installed it successfully, but what is much better?

    Birger :)
  11. mistwang

    mistwang LiteSpeed Staff

    The new release still do not allow symbolic link to a directory out side virtual host root, so if you want to share phpMyAdmin code among many users, you have to configure it through "Alias" in httpd.conf, or "Static Context" from LSWS console.

    That's the way to bring external directories beyond vhost root into the document root.

    Or, disable "Restrained" option.
  12. MindTooth

    MindTooth New Member

    Thank you for the reply, but this is beyond my knowledge. I just disabled Restrained.

    Birger :)
  13. andreas

    andreas New Member

    Thanks, 4.0.3 fixes it.
  14. andreas

    andreas New Member

    Oops, I detected a bug with 4.0.3:

    I have a symlink called "b" that links to a directory "a". In 4.0, if I access blabla.com/b/index.php, the working directory for index.php is "b". In 4.0.3, the working directory is "a". It looks like LSWS resolves the symlink instead of just running b/index.php.
  15. andreas

    andreas New Member

    The behaviour still exists in 4.0.5. Are you planning to fix this in a future release, or do I need to find a different solution to my problem?

Share This Page