Abort request processing on DDoS IPs

Discussion in 'General' started by Jingle, Aug 24, 2013.

  1. Jingle

    Jingle New Member

    Hi, I am getting abort request processing on a DDoS attack with around 500 bots when Litespeed should be detecting them as bots and should be blocking them which it isn't.


    Here's a log

    2013-08-23 22:01:07.105 INFO [72.32.36.154:48371-0#APVH_xxx.org] Abort request processing by PID:7195, kill: 1, begin time: 1, sent time: 1, req processed: 17
    2013-08-23 22:01:08.001 INFO [CLEANUP] Send signal: 10 to process: 7195
    2013-08-23 22:01:10.251 INFO [193.189.74.98:48082-0#APVH_xxx.org] Abort request processing by PID:6207, kill: 1, begin time: 1, sent time: 1, req processed: 65
    2013-08-23 22:01:11.001 INFO [CLEANUP] Send signal: 10 to process: 6207
    2013-08-23 22:01:12.429 INFO [27.34.158.1:21621-0#APVH_xxxx.org] Abort request processing by PID:7125, kill: 1, begin time: 1, sent time: 1, req processed: 11
    2013-08-23 22:01:13.004 INFO [CLEANUP] Send signal: 10 to process: 7125
    2013-08-23 22:01:14.301 INFO [108.168.213.82:14386-0#APVH_xxxx.org] Abort request processing by PID:7203, kill: 1, begin time: 1, sent time: 1, req processed: 17
    2013-08-23 22:01:19.308 INFO [210.224.185.85:34031-0#APVH_xxx.org] Abort request processing by PID:7553, kill: 1, begin time: 1, sent time: 1, req processed: 7




    I need some assistance please, thank you.
  2. sahith

    sahith New Member

    I also facing similar errors, can anyone help?
  3. NiteWave

    NiteWave Administrator

    those log are INFO level. can be ignored.
  4. Nandhakumar

    Nandhakumar New Member

    i have been faced the following problem in my litespeed web server often so when this problem happens then my litespeed server won't serve the requests to users so my business got so much of lack due to this problem. once we made the reboot action( server reboot and litespeed restart) then site available to use. i have tried the the following solution
    http://www.litespeedtech.com/support/forum/threads/lots-of-abort-requests.7444/ but it won't works for me either. please get me the solution ASAP.

    The problem is,

    2014-06-25 10:40:02.000 [INFO] [CLEANUP] Send signal: 10 to process: 19241
    2014-06-25 10:40:05.388 [INFO] [10.189.245.5:23300-0#APVH_*:443_] Abort request processing by PID:19242, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:40:05.388 [INFO] [10.189.245.7:40231-0#APVH_*:443_] Abort request processing by PID:19243, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:40:06.000 [INFO] [CLEANUP] Send signal: 10 to process: 19243
    2014-06-25 10:40:06.000 [INFO] [CLEANUP] Send signal: 10 to process: 19242
    2014-06-25 10:40:06.388 [INFO] [10.189.245.8:29939-0#APVHost1][ACL] Access to context [/] is denied!
    2014-06-25 10:40:06.489 [INFO] [10.189.245.4:20689-0#APVH_*:443_] Abort request processing by PID:19244, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:40:07.000 [INFO] [CLEANUP] Send signal: 10 to process: 19244
    2014-06-25 10:40:08.514 [INFO] [10.189.245.6:37879-0#APVHost1][ACL] Access to context [/] is denied!
    2014-06-25 10:40:09.706 [INFO] [10.189.245.5:21742-0#APVHost1][ACL] Access to context [/] is denied!
    2014-06-25 10:40:09.907 [INFO] [10.189.245.6:36015-0#APVH_*:443_] Abort request processing by PID:19245, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:40:10.000 [INFO] [CLEANUP] Send signal: 10 to process: 19245
    2014-06-25 10:41:08.517 [INFO] [10.189.245.6:24331-0#APVHost1][ACL] Access to context [/] is denied!
    2014-06-25 10:41:09.712 [INFO] [10.189.245.5:39673-0#APVHost1][ACL] Access to context [/] is denied!
    2014-06-25 10:41:10.388 [INFO] [10.189.245.5:42375-0#APVH_*:443_] Abort request processing by PID:19410, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:41:10.389 [INFO] [10.189.245.7:49304-0#APVH_*:443_] Abort request processing by PID:19413, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:41:11.000 [INFO] [CLEANUP] Send signal: 10 to process: 19413
    2014-06-25 10:41:11.000 [INFO] [CLEANUP] Send signal: 10 to process: 19410
    2014-06-25 10:41:11.491 [INFO] [10.189.245.4:37271-0#APVH_*:443_] Abort request processing by PID:19513, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:41:12.000 [INFO] [CLEANUP] Send signal: 10 to process: 19513
    2014-06-25 10:41:14.608 [INFO] [162.209.61.120:41224-0#APVHost1][ACL] Access to context [/] is denied!
    2014-06-25 10:41:14.909 [INFO] [10.189.245.6:20288-0#APVH_*:443_] Abort request processing by PID:19534, kill: 0, begin time: 10, sent time: 10, req processed: 0
    2014-06-25 10:41:15.000 [INFO] [CLEANUP] Send signal: 10 to process: 19534
    Last edited: Jun 26, 2014
  5. NiteWave

    NiteWave Administrator

    what's your lsws version? to ensure you're using the latest 4.2.12
    to ensure this, run at command line:
    #/usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.12

    another clue, check your tmpwatch cron job, try to exclude /tmp/lshttpd from it, see if any difference

Share This Page