always get Pragma:no-cache

Discussion in 'LiteSpeed Cache' started by nullx8, Dec 13, 2013.

  1. nullx8

    nullx8 New Member

    hello .. somehow the cache seems now to work at all.

    even ig clobally and vhost based enabled
    there is never a X Header about a cache hit.

    however the real time stats showing about 1% of the pages beeing cached.

    can someone may point me in the right direction ?

    all the pages i checked however have this returned headers:
    Code:
    HTTP/1.1 200 OK
    Transfer-Encoding: chunked
    Date: Fri, 13 Dec 2013 03:24:55 GMT
    Server: LiteSpeed
    Connection: close
    X-Powered-By: PHP/5.4.4
    Expires: Thu, 19 Nov 1981 08:52:00 GMT
    Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
    Pragma: no-cache
    Content-Type: text/html
    

    global config:
    Code:
    Enable Cache - no
    Cache Request with Query String - yes
    
    Virtual host config
    Code:
    Enable Cache - Yes
    Cache Request with Query String - yes
    
    htaccess
    Code:
    Options +FollowSymlinks
    RewriteEngine on
    
    RewriteRule .* - [E=Cache-Control:max-age=36]
    RewriteCond $1 !^(index\.php|lib/|i3/|tmp/|static/|theme/|robots\.txt|favicon\.ico)
    RewriteRule ^(.*)?$ index.php?go=$1 [L,E=Cache-Control:max-age=39]
    

    everything seems very straight forward

    any ideas ?
    Last edited: Dec 13, 2013
  2. NiteWave

    NiteWave Administrator

    please show the complete settings of global and vhost configuration.
  3. nullx8

    nullx8 New Member

    sorry here they are:

    global:
    Code:
    Storage Path	/ramtmp/lsws
    Max Object Size	Not Set
    
    Enable Cache	No
    Cache Expire Time (seconds)	300
    Cache Stale Age (seconds)	Not Set
    Cache Request with Query String	Yes
    Cache Request with Cookie	No
    Cache Response with Cookie	No
    Ignore Request Cache-Control	No
    Ignore Response Cache-Control	No
    Enable Private Cache	No
    Private Cache Expire Time (seconds)	0
    
    Do-Not-Cache URL     Not Set
    Do-Not-Cache Domains     Not Set
    
    Vhost:
    Code:
    Enable Cache	No
    Cache Expire Time (seconds)	30
    Cache Stale Age (seconds)	Not Set
    Cache Request with Query String	Yes
    Cache Request with Cookie	No
    Cache Response with Cookie	No
    Ignore Request Cache-Control	No
    Ignore Response Cache-Control	No
    Enable Private Cache	No
    Private Cache Expire Time (seconds)	20
    
  4. NiteWave

    NiteWave Administrator

    in vhost conf:
    set these NO to YES

    see if much difference.
  5. nullx8

    nullx8 New Member

    no difference.
    howevr i got it working by turn chache ON in vhost config

    Code:
    Cache ON
    Cache Expire Time (seconds)	300
    Cache Stale Age (seconds)	Not Set
    Cache Request with Query String	Yes
    
    and htaccess disable cache by default works.

Share This Page