Another Problem - Now it is Configuration issue

Discussion in 'Install/Configuration' started by glueJoe, Aug 4, 2006.

  1. glueJoe

    glueJoe New Member

    Hi, thanks to your soft I've expected a whole variety of feelings, tasted never before. Great fun. :)

    Nevertheless, my life was a bit wasted by the thing that installation made me change some file attributes to ensure that server user (configured to run server) could write to config files in server directory($SERV_ROOT/...***). Thus I managed to overcome first problems - LiteSPeed'y could'n save it's config. Then I breathed openly (and loudly). But things didn't make much better. Second (unmatched by me) problem lies in adjacent field - server clearly has problems with Vhosts and Listening Ports. In fact he does not manage to save these settings and conclusively gets errors in misconfiguration. For me it is a deep blue sea. I started to delete some unneeded configs (ports and virt. hosts in the left panel) but it did nothing.

    Below is my log. I will ve very glad if point me what I have done wrong or haven't done:

    Here I uploaded .pdf file expressing server troubles after command: "lswsctrl start".

    I clearly understand the solution of logging issue in end of log. There is no need of explaining it to me. But the rest remains vague and also frightening :eek:.

    Thanks.
    See you soon.
    --
    I like what you do but this sometimes does what I don't like.
    Last edited: Aug 4, 2006
  2. mistwang

    mistwang LiteSpeed Staff

    Your problem is that another web server is using port 80, so litespeed cannot listen on port 80 again, change to another port like 81 if you cannot turn off the other web server.

    There are file/directory permission problem for the admin log files. A default installation should set permissions properly, you should not need to change it.

    Also in the log file, seems you firewall blocked localhost, so the web admin console cannot control web server.

    Try a default installation using "root" account and let web server use user "nobody", everything should work if you fix the firewall block localhost problem.
  3. glueJoe

    glueJoe New Member

    WOW. Thanks. Horrible it is. And it really is...

    As I found out today problem is not related to firewall - my host administration does not preconfigure firewalls on user VPS accounts. So it must be solidly a matter of Php (I get php warning each time gracefully restart system) or other unknown by me tweak:
    [​IMG]

    I personally can guess only some trivial matter such php.ini misconfig.
    There is no longer problem with access: user running server got chown -R /opt/lsws/.

    Also I am very troubled by the port issue, but I dare to think that happens because server can't properly update configuration: ports 443, 80 and 7080, although I deleted or changed them (all of them):
    [​IMG]

    Are still in use after cold restart (../lswsctrl restart):

    [​IMG]

    Provide that the changes were not made and the congifuration (presumption) stays unmodified, while the panel has this changes made, and so they struck with their heads.

    I clearly understand that my problem could be caused by my absolute folly, but It very hard to understand why, where and when?

    Btw. I don't mention problems with running cgi (also misconfig - ldconfig problem) and other minor incompatabilities such as:

    [​IMG]

    But they are at least minor and manageable.
    Thanks for help.
    Don't deserve your follower. ;) The difficulties are still overwhelming me.
    Last edited: Aug 5, 2006
  4. glueJoe

    glueJoe New Member

    THis time I post only to get yur attention to my last statement.

    Btw. I want to complain also about you forum - not about your participation in it , - it's yet perfect. The problem is with attachment sender of this very form. First is the underestimated 36 kb/file. You must why it is too little. Second is that even if the file is ok, I can't send it by my Mozilla Firefox 2.0. By all means - it is crappy php code. Oh. I hate so much these pre-built php forums....
  5. mistwang

    mistwang LiteSpeed Staff

    For the PHP socket connect problem, you can try it manually, the admin port is logged at the beginning of the log file, do 'netstat -an | grep <admin_port>", if you see a line contain "LISTEN", the admin port is in good shape, then do "telnet 127.0.0.1 <admin_port>", if you get connection refused, it is a firewall issue.

    Try to add a new listener on another port, and remove the port 80 listener. Looks like you changed the listener port from 8088 to 80.
  6. glueJoe

    glueJoe New Member

    Sorry, but I didn't get it clear. I will try to explain it one more time.
    First, I can get ports 80, 7080 and 443 properly used by LiteSpeed - they are already listeners for all for them. I have checked what you asked - all of them are mow in use.
    Once I restart sever with the default ports (80, 7080 and 443) this causes an error shown above. When I switch preferences to different ports, server starts effortlessly. I can't understand why this must happen. There is nothing such as firewall or smth (;)) set up on the machine too.

    As you can see on the screenshot above (with left part of dashboard) there is no multiple use of ports by the server (there is no other server running at the same time) and no firewall. What does it mean? I don't know.
    There is a thing with the admin panel - I deliberately changed its port (7080 maybe to 8081) but still it is reachable though 7080. Just to mention: new adress is working too...

    - It doesn't make any sence.
    - True.

    The fact is fighting with admin panel is the same as attackin' wall with own head. The preferences of server are right (in terms of nothing else other than needed is tunning) but the problems stay the same.
  7. xing

    xing LiteSpeed Staff

    Java socket servers exhibit similar problems where the "shutdown" of the java server processing binding to an arbitrary port such as "8081" does not mean "8081" port is released to the operating system in real-time. Sometimes there is a multiple second delay before another process can rebind to it.

    However, we have only seen problem like this with Java socket servers and not with socket servers with other languages.

    Try this following experiment.

    1) Start lsws. lswsctrl start. Make sure everything works.

    2) Shut down lsws. lswsctrl stop

    3) Check processes "ps -ax | grep lshttpd" to make sure all the LiteSpeed processes are dead.

    4) Start LiteSpeed again. lswsctrl start

    If lshttpd processses are gone and the 2nd litespeed start complains of non-binding of ports, you have an operating system problem or os config problem.
  8. glueJoe

    glueJoe New Member

    I took a lil' break but now I am back, soon as my nerves healed from nasty adventure.

    Guys, you must be magicians!!! I donna know what are you doing to me... After a simple restart everything worked, as it didn't after same manipulation many times before! I am shocked. These are my only words. Thanks. Now I can do everything - change ports, play with config and make this: :p :p :p too.

    Great. You've made miracle. So, you could write in your product feature sheat: "... and last remember - It is a MIRACLE that can not be neither underestimated nor understood".

    - :mad:
    - Not funny? For me it is!

    Chao. All the best.
    Last edited: Aug 12, 2006

Share This Page