auto index problem

Discussion in 'Install/Configuration' started by art182, Sep 4, 2008.

  1. art182

    art182 New Member

    hello. i've read this post http://www.litespeedtech.com/support/forum/showpost.php?p=8543&postcount=4

    ~:
    mv /usr/local/lsws/share/autoindex /usr/local/php5/
    cd /usr/local/lsws/share/
    ln -s /usr/local/php5/autoindex autoindex

    but still don't work

    log:
    [config:vhost:pub.kage.pl] Path of context location contains symbolic link or ownership does not match:/usr/local/lsws/share/autoindex/

    where is the problem ?

    sorry for english ;)
  2. mistwang

    mistwang LiteSpeed Staff

  3. art182

    art182 New Member

    Follow Symbolic Link

    No
    Check Symbolic Link

    No

    and still

    [config:vhost: pub.kage.pl] Path of context location contains symbolic link or ownership does not match:/usr/local/lsws/share/autoindex/

    hmm ?
    --------
    If I change directory of autoindex to default ( /share/autoindex; no symlink )
    and disable open_basedir no error in logs but

    error 403 :/


    edit:
    ohh :

    [83.220.100.17:15248-1#pub.kage.pl] Scripting is disabled for VHost [pub.kage.pl], context [/_autoindex/], access denied.

    php must be on ?

    so how can i on autoindex and off php for one vhost ?
    Last edited: Sep 4, 2008
  4. mistwang

    mistwang LiteSpeed Staff

    You can try latest 3.3.18 release by change the version number in the download link.

    PHP scripting is enabled under that directory while it is disable for the rest of the site.
  5. art182

    art182 New Member

    a have this same problem with version 4.0.2

    Follow Symbolic Link - No
    Auto Index - Yes

    and Error 403 :(
  6. mistwang

    mistwang LiteSpeed Staff

    Please try the latest 4.0.3 build by changing the version number in the download link.
  7. slimak

    slimak New Member

    The problem still occur for us. We get the "403 Forbidden" error for autoindex at LSWS 4.0.6, 4.0.7 and 4.0.9. The version LSWS 4.0.1 work properly without error.
  8. mistwang

    mistwang LiteSpeed Staff

  9. slimak

    slimak New Member

    No, in "User's home directory Only" problem still occur.

    The Follow Symbolic Link is set to Yes (tried also set to No).
    The Check Symbolic Link is set to No.

    At the same configuration it was/is working in version 4.0.1 and earlier.

Share This Page