AWstats are not secured by password

Discussion in 'Install/Configuration' started by SyNeo, Sep 8, 2005.

  1. SyNeo

    SyNeo New Member

    Hi.

    I set the AWstats today - it was really easy to do. The only problem with it is, that I can't secure the AWstats URL. I created a new authentication realm, with user/password, and assigned it to AWstats add-on. But it still allows to access the stats without any password.

    Any ideas? I'm using the latest version of lshttpd (2.1RC3).
  2. mistwang

    mistwang LiteSpeed Staff

    Please download RC3 package again, Should be fixed. :)
  3. SyNeo

    SyNeo New Member

    Thanks - this helped to resolve the issue.
  4. SyNeo

    SyNeo New Member

    Hi.

    I encountered another issue with awstats again, this time on a FreeBSD host. When the Authentication Realm is empty, the awstats can be accessed normally. But if it's enabled, any attempt to access the same link will lead to the site (which will throw a "not found" error).

    Any ideas? The version used is the latest 2.1.5.

    Thanks.
  5. SyNeo

    SyNeo New Member

    Hi.

    Just brining this post to the top, to indicate that the FreeBSD problem with AWStats authentication still exists.

    Thanks.
  6. mistwang

    mistwang LiteSpeed Staff

    Sorry for the late response. a lot need to be caught up after the vacation.

    I just tried awstats with authentication realm on FreeBSD 4.11, works fine.

    Please turn on debug logging by setting "Debug Level" to "HIGH", then check your error.log. it should tell you what happened. Pay attention the warning and error messages at server startup.

    Maybe there is something wrong with your htpasswd file, please check the permission. And you can try the realm on other context as well.

Share This Page