awstats bug - i think

Discussion in 'Bug Reports' started by rampage, Mar 21, 2006.

  1. rampage

    rampage New Member

    Content-type: text/html; charset= Cache-Control: public Last-Modified: Tue Mar 21 17:07:40 2006 Expires: Tue Mar 21 17:07:40 2006
    Error: Couldn't open config file "awstats.trinitaku.myftp.org.conf" nor "awstats.conf" after searching in path "wwwroot/cgi-bin,/etc/awstats,/usr/local/etc/awstats,/etc,/etc/opt/awstats": No such file or directory

    - Did you use the correct URL ?
    Example: http://localhost/awstats/awstats.pl?config=mysite
    Example: http://127.0.0.1/cgi-bin/awstats.pl?config=mysite
    - Did you create your config file 'awstats.trinitaku.myftp.org.conf' ?
    If not, you can run "/tools/awstats_configure.pl" from command line, or create it manually.

    Check config file, permissions and AWStats documentation (in 'docs' directory)


    ...
    i get that whenever i try to access my stats. first of all the config file is located at /home/users/taku/awstats/conf/awstats.TriniTaku.conf
    yet when i try to access the stats it says:
    Error: Couldn't open config file "awstats.trinitaku.myftp.org.conf" nor "awstats.conf" after searching in path
  2. mistwang

    mistwang LiteSpeed Staff

    What URL were you using to access awstats?

    You don't need to and should not specify "config" parameter with LSWS, just use a URL like
    http://your.domain/awstats/
  3. rampage

    rampage New Member

    http://trinitaku.com/webstats

    and that is the url i use, when i go to it, that is the msg i see

    this is what i have in my litespeed web server config:
    AWStats Integration Edit
    Update Mode Static
    Working Directory $VH_ROOT/awstats/
    AWStats URI /webstats/
    Site Domain trinitaku.com
    Site Aliases 127.0.0.1 localhost REGEX[trinitaku.com]
    Update Interval Hourly
    Update Offset (secs) 0
    Secured Connection No
    Authentication Realm N/A
  4. mistwang

    mistwang LiteSpeed Staff

    What name is used for this vhost? have you changed it?
    Maybe you should remove the working directory and let LSWS configure awstats from scratch.
  5. rampage

    rampage New Member

    vhost name = TriniTaku
    never changed vhost name but i did change the awstats domain name from trinitaku.myftp.org to trinitaku.com. even if i change it back to trinitaku.myftp.org i get the same problem

    removed the working dir, same problem
  6. rampage

    rampage New Member

    i got it to display stats but it just isn't updating the stats now :

    http://trinitaku.com/stats/

    you will notice that a couple days are not accounted for.
  7. mistwang

    mistwang LiteSpeed Staff

    Please check the permission of the working directory and the log file.
  8. rampage

    rampage New Member

    permissions were always at 777.

    i think i found the problem:
    it's looking for the logfile as "accesslog.awstats" when the log file is really just "accesslog". I tried going into the litespeed admin panel and setting the log filename as "accesslog.awstats", and when the stats ran it looked for "accesslog.awstats.awstats". It keeps trying to add .awstats at the end of the filename.

    Is there a way fix that?
  9. mistwang

    mistwang LiteSpeed Staff

    Don't change the log file name, just let LSWS handle that for you. if you see accesslog.awstats, just remove it.
  10. rampage

    rampage New Member

    well i reinstalled the webserver and it works fine now. thx for the help!

Share This Page